Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 478297 - problem with blitz-devel (with fix)
Summary: problem with blitz-devel (with fix)
Keywords:
Status: CLOSED DUPLICATE of bug 450999
Alias: None
Product: Fedora
Classification: Fedora
Component: blitz
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-27 15:14 UTC by Mark van Rossum
Modified: 2008-12-27 15:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-27 15:58:06 UTC


Attachments (Terms of Use)

Description Mark van Rossum 2008-12-27 15:14:49 UTC
Description of problem:

I found that the the FC9 package of blitz-devel does not work
on FC10.

Version-Release number of selected component (if applicable):
blitz-devel-0.9-7.fc9.i386 on fc10

How reproducible:
Always on my box.

Steps to Reproduce:
1. install blitz-devel
2. try to compile program that 
  
Actual results:
/usr/include/blitz/bzconfig.h:39:32: error: blitz/gnu/bzconfig.h: No such file or directory


Expected results:


FIX:

Edit /usr/include/blitz/bzconfig.h  to be:

#elif defined(__GNUC__)
/* GNU gcc compiler */
// #include <blitz/gnu/bzconfig.h>
#include "/usr/lib/blitz/include/blitz/gnu/bzconfig.h"



Note, I never tried it in FC9, maybe it was broken there as well...

Comment 1 Sergio Pascual 2008-12-27 15:58:06 UTC
If you compile your program with  
$  g++ myprogram.cc `pkg-config blitz --libs --cflags`
it should work

See bug #450999 for references

*** This bug has been marked as a duplicate of bug 450999 ***


Note You need to log in before you can comment on or make changes to this bug.