Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 477228 - Unable to cancel actions using schedule.cancelActions
Summary: Unable to cancel actions using schedule.cancelActions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: API
Version: 0.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brad Buckingham
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-12-19 18:44 UTC by Brad Buckingham
Modified: 2009-01-22 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:31:26 UTC


Attachments (Terms of Use)
Exception details from catalina.out (deleted)
2008-12-19 18:44 UTC, Brad Buckingham
no flags Details

Description Brad Buckingham 2008-12-19 18:44:27 UTC
Created attachment 327482 [details]
Exception details from catalina.out

Description of problem:

Attempting to cancel an action using the schedule.cancelActions() api generates an exception that is thrown back to the user as well as logged in catalina.out.  The exception generated is new since the integration with cobbler and is related to a kickstart query.

See attachment for the detailed error from catalina.out.



Version-Release number of selected component (if applicable):
Testing w/ latest git master as of Dec 19.

How reproducible:
always

Steps to Reproduce:
1. schedule an action to 
(e.g. client.system.scheduleHardwareRefresh(key,1000020124, <earliest>))
2. attempt to schedule the action using the api:
client.schedule.cancelActions(key, [<actionId>])

  
Actual results:
Exception generated (however, action is canceled)

Expected results:
Action cancelled without exception

Additional info:
See attachment

Comment 1 Brad Buckingham 2009-01-09 23:40:46 UTC
git commit: 5273454049014a5be9ed73b689c4d53115295bec


The ActionManager.cancelAction was deleting the ServerAction before it was finished using it.  Basically, it would delete the ServerActions then perform action.getServerActions resulting in an empty list.  When this empty list was passed to KickstartFactory.failKickstartSessions, the hibernate query could generate an exception because it expected the servers collection (i.e. list passed) to have contents.


Note You need to log in before you can comment on or make changes to this bug.