Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 477057 - ISE when submitting a system to "Enable Spacewalk Configuration Management"
Summary: ISE when submitting a system to "Enable Spacewalk Configuration Management"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.4
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brad Buckingham
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-12-18 21:15 UTC by John Matthews
Modified: 2009-01-22 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:31:22 UTC


Attachments (Terms of Use)

Description John Matthews 2008-12-18 21:15:50 UTC
Description of problem:
Registered a system to spacewalk master (0.4 code from 12/18).
Gave provisioning entitlement, then attempted to enabled configuration management and got an ISE.

Might be multi-arch related

Version-Release number of selected component (if applicable):
spacewalk from master, code was from 12/18


How reproducible:
Always

Steps to Reproduce:
1. Register a system
2. Give it provisioning entitlement
3. Go to: /rhn/configuration/system/TargetSystemsSubmit.do
4. Select the system you registered and gave provision entitlement to. Ensure check box is clicked.
5. Click "Enable Spacewalk Configuration Management"

Actual results:
ISE

Expected results:
Success page 

Additional info:  I tried this with both a rhel5-i386 client on a rlx machine and a vmware guest running rhel4-i386.  Reproduced with both cases.


2008-12-18 16:11:06,497 [TP-Processor11] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException: Could not set null value for parameter: arch_id
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
	at java.lang.Thread.run(Thread.java:636)
Caused by: com.redhat.rhn.common.db.datasource.ParameterValueNotFoundException: Could not set null value for parameter: arch_id
	at com.redhat.rhn.common.db.datasource.CachedStatement.setupParamMap(CachedStatement.java:414)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:448)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
	at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
	at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:32)
	at com.redhat.rhn.manager.action.ActionManager.schedulePackageAction(ActionManager.java:1464)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.installPackages(EnableConfigHelper.java:226)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystem(EnableConfigHelper.java:115)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystems(EnableConfigHelper.java:85)
	at com.redhat.rhn.manager.configuration.ConfigurationManager.enableSystems(ConfigurationManager.java:1890)
	at com.redhat.rhn.frontend.action.configuration.overview.TargetSystemsSubmitAction.enableSystems(TargetSystemsSubmitAction.java:99)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:270)
	at org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:187)
	at org.apache.struts.actions.LookupDispatchAction.execute(LookupDispatchAction.java:150)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 40 more
2008-12-18 16:11:06,497 [RHN Message Dispatcher] WARN  com.redhat.rhn.common.messaging.SmtpMail - Address admin@example.com not in restricted domains list
2008-12-18 16:11:06,510 [RHN Message Dispatcher] WARN  com.redhat.rhn.common.messaging.SmtpMail - Aborting mail message WEB TRACEBACK from jwm-devel.home (12/18/08 4:11:06 PM GMT-05:00): No recipients
2008-12-18 16:11:06,598 [TP-Processor11] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn].[action] - Servlet.service() for servlet action threw exception
com.redhat.rhn.common.db.datasource.ParameterValueNotFoundException: Could not set null value for parameter: arch_id
	at com.redhat.rhn.common.db.datasource.CachedStatement.setupParamMap(CachedStatement.java:414)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:448)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
	at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
	at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:32)
	at com.redhat.rhn.manager.action.ActionManager.schedulePackageAction(ActionManager.java:1464)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.installPackages(EnableConfigHelper.java:226)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystem(EnableConfigHelper.java:115)
	at com.redhat.rhn.manager.configuration.EnableConfigHelper.enableSystems(EnableConfigHelper.java:85)
	at com.redhat.rhn.manager.configuration.ConfigurationManager.enableSystems(ConfigurationManager.java:1890)
	at com.redhat.rhn.frontend.action.configuration.overview.TargetSystemsSubmitAction.enableSystems(TargetSystemsSubmitAction.java:99)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:270)
	at org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:187)
	at org.apache.struts.actions.LookupDispatchAction.execute(LookupDispatchAction.java:150)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
	at java.lang.Thread.run(Thread.java:636)

Comment 1 John Matthews 2008-12-22 18:48:37 UTC
This is working for me now.  I assume it got fixed in the past few days.

Using latest git checkout of Master (12/22) and setup 2 systems for configuration management.

Comment 2 John Matthews 2008-12-22 19:06:14 UTC
Please ignore comment #1, turns out this is still an issue.

Comment 3 Brad Buckingham 2009-01-12 15:03:10 UTC
Updated w/ commit: 5402b0772ef4352c92df399839376902195b7db3

In order to support multi-arch, the ActionManager.schedulePackageAction was updated to support arch_id; however, it required it to always exist.  There are cases, such as this one, where we want to schedule a package action, but the arch_id is not specified.  This commit will enable arch_id to be optional.

Comment 4 Brad Buckingham 2009-01-15 15:31:30 UTC
verified on spacewalk-java-0.4.14-1.el5


Note You need to log in before you can comment on or make changes to this bug.