Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4758 - lilo fails to pass command line on Intel SC450NX, which can hose root partition info
Summary: lilo fails to pass command line on Intel SC450NX, which can hose root partiti...
Keywords:
Status: CLOSED DUPLICATE of bug 5165
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 2720 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-27 19:30 UTC by curt
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-05 06:22:24 UTC


Attachments (Terms of Use)

Description curt 1999-08-27 19:30:27 UTC
Arguments passed to the lilo boot prompt do not reach the
kernel.  Even the default ones setup by lilo (like BOOT=)
don't make it.  Try "cat /proc/cmdline".  This will
sometimes cause kernels to not boot, and I'd assume that it
would not boot kernels installed on a disk other than the
kernel default boot device.

Probably not the desired effect for a "Red Hat Certified
System". ;)

BTW: Grub works fine

Comment 1 Cristian Gafton 1999-09-20 15:19:59 UTC
*** Bug 2720 has been marked as a duplicate of this bug. ***

On an Intel Sitka Platform (4-way Xeon, Symbios 896
on-board SCSI) after initial installation the install kernel
panic's (not able to find root filesystem).  I have talked
to Doug Ledford at Red Hat and he says this is a known
problem and was thought to be fixed in a beta version.  We
have recreated the problem on several Sitka's at Intel
using Red Hat 6.0 Gold.

------- Additional Comments From jxh@msi.com  05/10/99 17:19 -------
It seems that something goes wrong in parsing the lilo.conf file. If
I use the lilo.conf file installed by default everything works fine.
But if I replace the
prompt
timeout=50
sequence
with
delay=20
the kernel panics (not able to find root file system). This is on a
Dell Inspiron 3200.

------- Additional Comments From dledford@redhat.com  05/13/99 01:54 -------
A new lilo version is now under testing from Werner Almesberger.  We
will be working with him on this and should have an updated version
soon.  The test version currently available is lilo-22dev0 and is
available from the ftp site
ftp://lrcftp.epfl.ch/pub/people/almesber/lilo/lilo-22dev0.tar.gzDoug is working on a fix for this.

Comment 2 Cristian Gafton 1999-10-05 06:22:59 UTC
*** This bug has been marked as a duplicate of 5165 ***


Note You need to log in before you can comment on or make changes to this bug.