Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 475324 - System Set Manager->Package->Upgrade: support for multiarch
Summary: System Set Manager->Package->Upgrade: support for multiarch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.3
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-12-08 21:19 UTC by Jason Dobies
Modified: 2009-02-11 20:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:31:03 UTC


Attachments (Terms of Use)

Description Jason Dobies 2008-12-08 21:19:29 UTC
Description of problem:

Upgrading packages (systems->ssm->packages->upgrade)

BZ for tracking the porting of the SSM upgrade pages from perl to Java as well as adding support for multiarch.

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

Associate a system with SSM:
1. select Systems
2. click the box next to an x86_64 system

Upgrade a package using SSM:
3. select System Set Manager -> Upgrade
4. schedule install of i386 package (e.g. libjpeg)
5. run rhn_check -vvv on client at appropriate time to install the package

Actual results:
x86_64 package installed on client

Expected results:
i386 package installed on client

Additional info:

Comment 1 Jason Dobies 2008-12-08 21:47:32 UTC
Commit: cdd16819a0f5066474225ac7316973cf72d0bfb4

Comment 2 Jason Dobies 2008-12-09 15:14:44 UTC
Further commits:

Cleaned up query - a6be0193bc1874fa27d4848f98b34e52c52fa1dd
Removes perl pages - 55076ec96637b7ee7f761aa0683b848f14e725f7
Fixed CSS on packages table - 659d27544b049a324a234d7db22c94f25f433f26


Note You need to log in before you can comment on or make changes to this bug.