Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 474306 - Oracle Error while Activating Satellite
Summary: Oracle Error while Activating Satellite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 0.3
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-12-03 08:18 UTC by Cem Vedat ISIK
Modified: 2009-01-22 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:31:00 UTC


Attachments (Terms of Use)
Spacewalk Installation Log from /var/log/rhn/rhn-installation.log (deleted)
2008-12-03 08:19 UTC, Cem Vedat ISIK
no flags Details

Description Cem Vedat ISIK 2008-12-03 08:18:22 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111317 Ubuntu/8.04 (hardy) Firefox/3.0.4

During spacewalk-setup --disconnected after database population,

* Setting up users and groups.
** GPG: Initializing GPG and importing key.
* Performing initial configuration.
* Activating Satellite.
** Loading Satellite Certificate.
** Verifying certificate locally.
** Activating Satellite.
There was a problem validating the satellite certificate: 1

Attached log shows addresses an Oracle problem. However, during installation the permissions for /etc are reset by perl-Satcon, In /var/log/rhn/rhn-installation.log, I see
        /etc/sysconfig/rhn-satellite-prep/etc -> /etc
It seems like Oracle probably couldn't read something from /etc which it felt needed to get the job done.

Reproducible: Always

Steps to Reproduce:
1. #spacewalk-setup --disconnected
2.
3.
Actual Results:  
[root@vm905 ~]# spacewalk-setup --disconnected
* Loading answer file: /usr/share/spacewalk/setup/defaults.conf.
Only one database option available, assuming: oracle
* Setting up Oracle environment.
* Setting up database.
** Database: Setting up database connection.
DB User? spacewalk
DB Password?
DB SID? xe
DB hostname? localhost
DB port [1521]?
DB protocol [TCP]?
** Database: Testing database connection.
** Database: Populating database.
sh: dbhome: command not found
*** Progress:
#################################################################
* Setting up users and groups.
** GPG: Initializing GPG and importing key.
* Performing initial configuration.
* Activating Satellite.
** Loading Satellite Certificate.
** Verifying certificate locally.
** Activating Satellite.
There was a problem validating the satellite certificate: 1

Expected Results:  
Activate the satellite and continue installation

Here are the software components I've been using

Red Hat Enterprise Linux Server release 5.2 (Tikanga) 2.6.18-92.1.6.el5

oracle-instantclient-basic-10.2.0.4-1
oracle-instantclient-devel-10.2.0.4-1
oracle-instantclient-jdbc-10.2.0.4-1
oracle-instantclient-sqlplus-10.2.0.4-1
oracle-lib-compat-10.2-13.el5.sw
oracle-xe-client-10.2.0.1-1.0
oracle-xe-univ-10.2.0.1-1.0
rhn-oracle-jdbc-1.0-20.el5.sw
rhn-oracle-jdbc-tomcat5-1.0-20.el5.sw
spacewalk-0.3.6-1.el5.sw
spacewalk-admin-0.3.3-1.el5.sw
spacewalk-backend-0.3.3-1.el5.sw
spacewalk-backend-app-0.3.3-1.el5.sw
spacewalk-backend-applet-0.3.3-1.el5.sw
spacewalk-backend-config-files-0.3.3-1.el5.sw
spacewalk-backend-config-files-common-0.3.3-1.el5.sw
spacewalk-backend-config-files-tool-0.3.3-1.el5.sw
spacewalk-backend-package-push-server-0.3.3-1.el5.sw
spacewalk-backend-server-0.3.3-1.el5.sw
spacewalk-backend-sql-0.3.3-1.el5.sw
spacewalk-backend-tools-0.3.3-1.el5.sw
spacewalk-backend-xml-export-libs-0.3.3-1.el5.sw
spacewalk-backend-xmlrpc-0.3.3-1.el5.sw
spacewalk-backend-xp-0.3.3-1.el5.sw
spacewalk-base-0.3.7-1.el5.sw
spacewalk-branding-0.1.6-1.el5.sw
spacewalk-certs-tools-0.2.3-1.el5.sw
spacewalk-config-0.3.3-1.el5.sw
spacewalk-cypress-0.3.7-1.el5.sw
spacewalk-dobby-0.3.7-1.el5.sw
spacewalk-grail-0.3.7-1.el5.sw
spacewalk-html-0.3.7-1.el5.sw
spacewalk-java-0.3.8-1.el5.sw
spacewalk-java-config-0.3.8-1.el5.sw
spacewalk-java-lib-0.3.8-1.el5.sw
spacewalk-moon-0.3.7-1.el5.sw
spacewalk-pxt-0.3.7-1.el5.sw
spacewalk-repo-0.3-1.el5.sw
spacewalk-schema-0.3.6-1.el5.sw
spacewalk-search-0.3.5-1.el5.sw
spacewalk-setup-0.3.7-1.el5.sw
spacewalk-sniglets-0.3.7-1.el5.sw
spacewalk-taskomatic-0.3.8-1.el5.sw

Comment 1 Cem Vedat ISIK 2008-12-03 08:19:37 UTC
Created attachment 325496 [details]
Spacewalk Installation Log from /var/log/rhn/rhn-installation.log

Comment 2 Jan Pazdziora 2008-12-12 10:46:05 UTC
The problems stems from the fact that the permissions of the /etc/sysconfig/rhn-satellite-prep/etc directory are dependent on the umask. Which in turn is caused by the fact that this directory is not owned by any package (not even) spacewalk-config.

I believe that the correct fix is to add /etc/sysconfig/rhn-satellite-prep/etc to spacewalk-config's %files list.

Comment 3 Jan Pazdziora 2008-12-12 13:59:39 UTC
Fix commited in 26dfb87e817970074b7268dac14b5b1b9f57047a and 5cd50efd750c8c4e1526c81da01dac61ebd6cb2a.

Comment 4 Miroslav Suchý 2009-01-15 09:50:20 UTC
I activated satellite without problem.
VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.