Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4737 - scsi bus resets after upgrade to 2.2.5-22
Summary: scsi bus resets after upgrade to 2.2.5-22
Keywords:
Status: CLOSED DUPLICATE of bug 4608
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: sparc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-27 02:31 UTC by rddavis1
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 22:12:06 UTC


Attachments (Terms of Use)

Description rddavis1 1999-08-27 02:31:10 UTC
I have a Sun Sparc5, and after upgrading my kernel from
2.2.5-15 to 2.2.5-22, I get numerous scsi bus resets that
I didn't get before the upgrade.

In /var/log/messages, besides the scsi bus reset messages,
another message I noticed was "AIEEE wide msg received and
not HME".

After looking around in the source code, I saw that the
message originates from /usr/src/linux/drivers/scsi/esp.c
function - check_multibyte_msg().

The scsi bus resets occur in two cases on my machine:

1.  during the boot sequence

    During the boot sequence, just before the login screen
    appears, the disk drive starts clicking (meaning the
    scsi bus resets are occurring).  It clicks for almost
    2 minutes with just the blue blank screen before the
    Redhat login screen appears.

2.  Whenever a command involving files on my second disk
    drive is run.  (i.e. ls, cp, mv, etc.)


From the file /var/log/dmesg...

using fastest function: SPARC (57.150 MB/sec)
esp0: IRQ 36 SCSI ID 7 Clk 40MHz CCF=8 TOut 167
NCR53C9XF(espfast)
ESP: Total of 1 ESP hosts found, 1 actually in use.
scsi0 : Sparc ESP100A-FAST
scsi : 1 host.
 Vendor: SEAGATE   Model: ST5660N  SUN0535  Rev: 0644
  Type:   Direct-Access                      ANSI SCSI
revision: 02
Detected scsi disk sda at scsi0, channel 0, id 1, lun 0
esp0: AIEEE wide msg received and not HME.
esp0: hoping for msgout
  Vendor: COMPAQ    Model: ST34501WC         Rev: AF03
  Type:   Direct-Access                      ANSI SCSI
revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 3, lun 0
  Vendor: TOSHIBA   Model: XM-4101TASUNSLCD  Rev: 1084
  Type:   CD-ROM                             ANSI SCSI
revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 6, lun 0

===========================================================


Output from --->  cat /proc/scsi/esp/0


Sparc ESP Host Adapter:
        PROM node               ffd3d230
        PROM name               esp
        ESP Model               FAS100A
        DMA Revision            Rev 2
        Live Targets            [ 1 3 6 ]

Target #   config3    Sync Capabilities  Disconnect Wide
1          00000003   [2f,04]            yes        no
3          0000000    [2f,04]            yes        no
6          00000001   [2f,04]            yes        no


==========================================================

a few lines from --->  /var/log/messages
(there are a bunch of these)


Aug 26 04:32:28 localhost kernel: esp0: Resetting scsi bus
Aug 26 04:32:28 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:28 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:28 localhost kernel: esp0: AIEEE wide msg
received and not HME.
Aug 26 04:32:28 localhost kernel: esp0: hoping for msgout
Aug 26 04:32:28 localhost kernel: esp0: Resetting scsi bus
Aug 26 04:32:28 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:28 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:29 localhost kernel: esp0: AIEEE wide msg
received and not HME.
Aug 26 04:32:29 localhost kernel: esp0: hoping for msgout
Aug 26 04:32:29 localhost kernel: esp0: Resetting scsi bus
Aug 26 04:32:29 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:29 localhost kernel: esp0: SCSI bus reset
interrupt
Aug 26 04:32:29 localhost kernel: esp0: AIEEE wide msg
received and not HME.
Aug 26 04:32:29 localhost kernel: esp0: hoping for msgout


==========================================================

If you can help, please let me know.


THANKS!!!

Richard Davis, Jr.

Comment 1 Bill Nottingham 1999-08-31 22:12:59 UTC
*** This bug has been marked as a duplicate of 4608 ***


Note You need to log in before you can comment on or make changes to this bug.