Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4735 - Whenever there is an nfs hangs servers crash.
Summary: Whenever there is an nfs hangs servers crash.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-27 00:54 UTC by davidr
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-15 22:16:01 UTC


Attachments (Terms of Use)

Description davidr 1999-08-27 00:54:00 UTC
We have like 15 Linux boxes mounting 4 nfs shares on 4
netapps. Whenever there is an nfs hang servers crash. Not
all servers but some.

Kernel 2.2.5-22

Snippet from message file.
Aug 25 00:26:09 af12 kernel: nfs_revalidate_inode:
images/Baffoon.wav getattr fa
iled, ino=2713956, error=-116
Aug 25 00:26:09 af12 kernel: NFS: bad fh
001a678003bbffe600000020646929001503815
600002ce0000000400018a5ca
Aug 25 00:26:09 af12 kernel:
001a678003bbffe600000020646929001503815
700002ce0000000400018a5ca
Aug 25 00:26:09 af12 kernel: nfs_revalidate_inode:
images/Baffoon.wav getattr fa
iled, ino=2713956, error=-116
Aug 25 00:26:09 af12 kernel: NFS: bad fh
001a678003bbffe600000020646929001503815
600002ce0000000400018a5ca
Aug 25 00:26:09 af12 kernel:
001a678003bbffe600000020646929001503815
700002ce0000000400018a5ca
Aug 25 00:36:22 af12 kernel: __nfs_fhget: inode 19725066
busy, i_count=2, i_nlin
k=1
Aug 25 00:36:22 af12 kernel: nfs_free_dentries: found
bmarkman/bretthome3.html,
d_count=0, hashed=1
Aug 25 00:36:22 af12 kernel: nfs_dentry_delete:
bmarkman/bretthome3.html: ino=19
725066, count=2, nlink=1
Aug 25 01:36:30 af12 syslogd 1.3-3: restart.

Compile options for kernel
CONFIG_M686=y
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_INVLPG=y
CONFIG_X86_BSWAP=y
CONFIG_X86_POPAD_OK=y
CONFIG_X86_TSC=y
CONFIG_X86_GOOD_APIC=y
CONFIG_1GB=y
CONFIG_MTRR=y
CONFIG_NET=y
CONFIG_PCI=y
CONFIG_PCI_GOANY=y
CONFIG_PCI_BIOS=y
CONFIG_PCI_DIRECT=y
CONFIG_PCI_QUIRKS=y
CONFIG_PCI_OLD_PROC=y
CONFIG_SYSVIPC=y
CONFIG_BSD_PROCESS_ACCT=y
CONFIG_SYSCTL=y
CONFIG_BINFMT_ELF=y
CONFIG_BLK_DEV_FD=y
CONFIG_BLK_DEV_LOOP=y
CONFIG_PARIDE_PARPORT=y
CONFIG_PACKET=y
CONFIG_NETLINK=y
CONFIG_NETLINK_DEV=y
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_ALIAS=y
CONFIG_SYN_COOKIES=y

CONFIG_SKB_LARGE=y

CONFIG_SCSI=y

CONFIG_BLK_DEV_SD=y
CONFIG_SCSI_AIC7XXX=y
CONFIG_AIC7XXX_CMDS_PER_DEVICE=8
CONFIG_AIC7XXX_PROC_STATS=y
CONFIG_AIC7XXX_RESET_DELAY=5
CONFIG_NETDEVICES=y

CONFIG_NET_ETHERNET=y
CONFIG_NET_EISA=y
CONFIG_EEXPRESS_PRO100=y
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=y
CONFIG_SERIAL_CONSOLE=y
CONFIG_PROC_FS=y
CONFIG_EXT2_FS=y
CONFIG_NFS_FS=y
CONFIG_SUNRPC=y
CONFIG_LOCKD=y

CONFIG_VGA_CONSOLE=y

Comment 1 Jeff Johnson 1999-08-27 14:38:59 UTC
What kernel and knfsd are you running? Could you try the latest
kernel/knfsd from Raw Hide and see if the problem is improved?
The latest packages in Raw Hide right now should be
	kernel-2.2.12-1
	knfsd-1.4.7-2

You might also attempt to mount with the "soft" option, although that
may cause other problems ...

Comment 2 Cristian Gafton 2000-02-15 22:16:59 UTC
closed due to lack of feedback


Note You need to log in before you can comment on or make changes to this bug.