Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 473297 - host(1) segfault
Summary: host(1) segfault
Keywords:
Status: CLOSED DUPLICATE of bug 452060
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-11-27 15:31 UTC by Jakub Hrozek
Modified: 2013-04-30 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-02 08:48:49 UTC


Attachments (Terms of Use)
b2zipped core file (deleted)
2008-11-27 15:31 UTC, Jakub Hrozek
no flags Details

Description Jakub Hrozek 2008-11-27 15:31:31 UTC
Created attachment 324893 [details]
b2zipped core file

Description of problem:
host(1) segfaults for me when asking about certain servers, right before it should output MX records:

[root@ipa-server local]# host redhat.com
redhat.com has address 209.132.177.50
Segmentation fault

This is a virtual machine, using libvirt's NAT network config. I have bind running on that machine that provides DNS for my virtual machines, unknown requests are forwarded to libvirt's default DNS:
----
----

AFAIK the segfault occurs only for requests from outside - i.e. when the local bind forwards the request.

Version-Release number of selected component (if applicable):
bind-utils-9.5.0-35.P2.fc9.i386

How reproducible:
not always, but often enough.

Steps to Reproduce:
1. host redhat.com
  
Actual results:
segfault

Expected results:
no segfault

Additional info:
core file attached. gdb session:

(gdb) r redhat.com
Starting program: /usr/bin/host redhat.com
[Thread debugging using libthread_db enabled]
[New Thread 0xb8028b00 (LWP 2186)]
[New Thread 0xb7fe5b90 (LWP 2189)]
[New Thread 0xb75e4b90 (LWP 2190)]
[New Thread 0xb6be3b90 (LWP 2191)]
redhat.com has address 209.132.177.50

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7fe5b90 (LWP 2189)]
send_udp (query=0xffffffff) at dighost.c:2328
2328		l = query->lookup;
(gdb) p query
$1 = (dig_query_t *) 0xffffffff

Comment 1 Jakub Hrozek 2008-11-27 15:32:52 UTC
Sorry, I also meant to show how the forwarding is configured:
-----
forward         first;
forwarders      { 192.168.122.1; };
allow-query     { localhost; 192.168.122.0/24; };
-----

Comment 2 Adam Tkac 2008-12-02 08:48:49 UTC

*** This bug has been marked as a duplicate of bug 452060 ***


Note You need to log in before you can comment on or make changes to this bug.