Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 472895 - Monitoring fails to start with new perl-Class-MethodMaker
Summary: Monitoring fails to start with new perl-Class-MethodMaker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-25 14:28 UTC by Miroslav Suchý
Modified: 2009-01-22 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:30:50 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2008-11-25 14:28:16 UTC
Description of problem:
When I run (with Monitoring and Monitoring Scout enabled):
  service Monitoring start 
I got this error:
...

2008-11-25 15:33:33 NPBootstrap: STARTING...
2008-11-25 15:33:34 NPBootstrap: No scheduler configuration found, getting it
2008-11-25 15:33:35 NPBootstrap: WARNING: scheduleEvents returned non-zero exit level
2008-11-25 15:33:35 NPBootstrap:        !! ERROR FROM SHELL COMMAND:
2008-11-25 15:33:35 NPBootstrap:        !! STDOUT:
2008-11-25 15:33:35 NPBootstrap:        !! STDERR: meta-method type grouped_fields not recognized as a V1 compatibility type
(cannot mix v1 & v2 options)
 at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Class/MethodMaker.pm line 20
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/ItemStatus.pm line 47.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/Schedule.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/Schedule.pm line 8.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 13.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 13.
Compilation failed in require at /usr/bin/scheduleEvents line 12.
BEGIN failed--compilation aborted at /usr/bin/scheduleEvents line 12.

2008-11-25 15:33:35 NPBootstrap:        !! EXIT: 2304
2008-11-25 15:33:35 NPBootstrap: START HAD ERRORS


Version-Release number of selected component (if applicable):
Spacewalk 0.3 + git patches

How reproducible:
always

Steps to Reproduce:
1. enable EPEL repo
2. install spacewalk
3. enable Monitoring
4. enable Monitoring Scout
5. /sbin/rhn-satellite restart
  
Actual results:
error above

Expected results:
no error

Additional info:
The problem is that Monitoring code is writen with V1 of Class::MethodMaker.
V2 of Class::MethodMaker do not support "grouped_fields", which we use.
We have in our repo perl-Class-MethodMaker-1.12. But in EPEL is perl-Class-MethodMaker-2.08. Therefore when you run yum upgrade MonitoringScout will stop working.

Comment 1 Jan Pazdziora 2008-11-25 14:57:17 UTC
So, Mirek, it's time you fixed that monitoring code, huh?

Comment 2 Miroslav Suchý 2008-12-17 09:17:45 UTC
Fixed by ecee30bc476245a179db94805b0b5efb98fe7dc8

Comment 3 Jan Pazdziora 2009-01-15 10:14:31 UTC
With the 2.08 version of Class::MethodMaker

  # rpm -q perl-Class-MethodMaker
  perl-Class-MethodMaker-2.08-4.el5

the following monitoring

  # rpm -q spacewalk-monitoring
  spacewalk-monitoring-0.4.3-1.el5

starts just fine:

# /usr/sbin/rhn-satellite start
Starting rhn-satellite...
Starting RHN Taskomatic...
Starting tomcat5:                                          [  OK  ]
Starting httpd:                                            [  OK  ]
2009-01-15 12:24:28 Monitoring: Debug level = 0
2009-01-15 12:24:28 Monitoring: Switches: start
2009-01-15 12:24:28 Monitoring: STARTING...
2009-01-15 12:24:28 InstallSoftwareConfig: STARTING...
2009-01-15 12:24:28 InstallSoftwareConfig: Grabbing local config info
2009-01-15 12:24:29 InstallSoftwareConfig: STARTED OK
2009-01-15 12:24:29 InstallSoftwareConfig: ============ STATUS ===============
2009-01-15 12:24:29 InstallSoftwareConfig: Last action: start
2009-01-15 12:24:29 InstallSoftwareConfig: STARTED and RUNNING
2009-01-15 12:24:29 InstallSoftwareConfig: ===================================
2009-01-15 12:24:29 GenerateNotifConfig: STARTING...
2009-01-15 12:24:29 GenerateNotifConfig: STARTED OK
2009-01-15 12:24:29 GenerateNotifConfig: ============ STATUS ===============
2009-01-15 12:24:29 GenerateNotifConfig: Last action: start
2009-01-15 12:24:29 GenerateNotifConfig: ** Can be installed for SysV startup **
2009-01-15 12:24:29 GenerateNotifConfig: Run levels: 3
2009-01-15 12:24:29 GenerateNotifConfig: Start sequence: 70
2009-01-15 12:24:29 GenerateNotifConfig: Stop sequence: 40
2009-01-15 12:24:30 GenerateNotifConfig: STARTED and RUNNING
2009-01-15 12:24:30 GenerateNotifConfig: GoGo options:
2009-01-15 12:24:30 GenerateNotifConfig: --fname=GenerateNotifConfig
2009-01-15 12:24:30 GenerateNotifConfig: --command=/usr/bin/generate-config
2009-01-15 12:24:30 GenerateNotifConfig: --user=nocpulse
2009-01-15 12:24:30 GenerateNotifConfig: --hbfile=/var/log/notification/generate_config.log
2009-01-15 12:24:30 GenerateNotifConfig: --hbfreq=300
2009-01-15 12:24:30 GenerateNotifConfig: --hbcheck=600
2009-01-15 12:24:30 GenerateNotifConfig: ===================================
2009-01-15 12:24:31 NotifEscalator: STARTING...
[...]
2009-01-15 12:24:47 InstallSoftwareConfig: STARTED and RUNNING
2009-01-15 12:24:47 InstallSoftwareConfig: ===================================
2009-01-15 12:24:47 NPBootstrap: STARTING...
2009-01-15 12:24:48 NPBootstrap: Found scheduler configuration file - not requesting one
2009-01-15 12:24:48 NPBootstrap: STARTED OK
2009-01-15 12:24:49 NPBootstrap: ============ STATUS ===============
2009-01-15 12:24:49 NPBootstrap: Last action: start
2009-01-15 12:24:49 NPBootstrap: STARTED and RUNNING
2009-01-15 12:24:49 NPBootstrap: Cluster Description: RHN Monitoring Satellite
2009-01-15 12:24:49 NPBootstrap: Cluster ID: a13fa9fd0eb5
2009-01-15 12:24:49 NPBootstrap: Node ID: 2
2009-01-15 12:24:49 NPBootstrap: ===================================
2009-01-15 12:24:49 SputLite: STARTING...
2009-01-15 12:24:49 SputLite: STARTED OK


Note You need to log in before you can comment on or make changes to this bug.