Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 472595 - Extreme kickstart performance problem
Summary: Extreme kickstart performance problem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike McCune
QA Contact: Jesus M. Rodriguez
URL:
Whiteboard:
: 470234 (view as bug list)
Depends On: 491978
Blocks: space04 swcobbler05 525339
TreeView+ depends on / blocked
 
Reported: 2008-11-21 22:06 UTC by Mike McCune
Modified: 2012-03-06 08:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 525339 (view as bug list)
Environment:
Last Closed: 2009-09-17 07:08:39 UTC


Attachments (Terms of Use)

Description Mike McCune 2008-11-21 22:06:36 UTC
Kickstarts from Spacewalk take roughly 2-3 times as long as they should and the load on the Spacewalk server is around 4-5 on rlx-0-04.rhndev.


The slowness starts as the machine is downloading packages from the Spacewalk box.  Watch top and you can see httpd and oracle taking up most of the resources on the box.

Comment 1 Justin Sherrill 2009-01-09 21:52:56 UTC
I think this may have just been a temporary problem, as the issue has gone away.  Moving to modified just to be tested.

Comment 2 Mike McCune 2009-01-28 22:54:43 UTC
Customers are still reporting this in 0.4.  Re-opening.

Comment 3 Mike McCune 2009-02-03 23:16:08 UTC
Short term workaround for this bug:

* Edit: /etc/httpd/conf.d/zz-spacewalk-server.conf

Add: EnableMMAP off, EnableSendfile off to the Directory stanza:

<Directory "/var/www/html">
        AllowOverride all
        EnableMMAP off
        EnableSendfile off
</Directory>

* Add this index to your database:

# sqlplus spacewalk/spacewalk@xe

SQL> CREATE INDEX rhn_package_path_idx
ON rhnPackage(id, path);

Comment 4 Jesus M. Rodriguez 2009-02-24 21:06:43 UTC

*** This bug has been marked as a duplicate of bug 470234 ***

Comment 5 Mike McCune 2009-02-24 22:32:07 UTC
*** Bug 470234 has been marked as a duplicate of this bug. ***

Comment 6 Mike McCune 2009-03-12 05:49:12 UTC
i have the java port of the kickstart file downloader 90% complete but it is failing a few of my testcases.  Might not make 0.5 but I may release packages right after 0.5 goes out.

Comment 7 Mike McCune 2009-03-23 21:19:51 UTC
ON_QA

Comment 8 Milan Zázrivec 2009-03-24 10:56:43 UTC
Greetings Mike, I think you forgot to create rhn_package_path_idx index
in the schema itself; right now the index is present in the sql upgrade
script (153-rhnPackage-pathidx.sql) only.

Comment 9 Michael Mráka 2009-03-24 13:08:18 UTC
FAILS_QA, see comment #8

Comment 10 Mike McCune 2009-03-25 17:17:20 UTC
will fix!

Comment 11 Mike McCune 2009-03-25 17:28:01 UTC
schema fix: 7b974a41d4ec7f7ea0bc02257ee5d90941b71ccb

Comment 12 Mike McCune 2009-03-25 20:49:11 UTC
This actually should still be in FAILS_QA.  Discovered some fatal errors while kickstarting systems so it should not be tested.

Comment 13 Jesus M. Rodriguez 2009-04-14 14:11:55 UTC
Spacewalk 0.5 released.

Comment 14 Miroslav Suchý 2009-09-17 07:08:39 UTC
Spacewalk 0.5 has been released for long time ago.


Note You need to log in before you can comment on or make changes to this bug.