Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 471785 - Annoying beep when typing keyboard
Summary: Annoying beep when typing keyboard
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 471504 (view as bug list)
Depends On:
Blocks: F10DesktopTarget
TreeView+ depends on / blocked
 
Reported: 2008-11-16 09:50 UTC by Mamoru TASAKA
Modified: 2008-12-03 14:41 UTC (History)
7 users (show)

Fixed In Version: 0.6.0-0.2008.11.17.3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-18 14:19:39 UTC


Attachments (Terms of Use)
dmesg (deleted)
2008-11-16 09:50 UTC, Mamoru TASAKA
no flags Details
Xorg.0.log (deleted)
2008-11-16 09:51 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2008-11-16 09:50:09 UTC
Created attachment 323712 [details]
dmesg

Description of problem:
When I 
- login to GNOME session
- launch something (like xterm and so on)
- type a, (backspace), 5, so on
my computer beeps, which is very annoying

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-109.fc10.i686
xorg-x11-drv-i810-2.5.0-3.fc10.i386
xorg-x11-server-Xorg-1.5.2-12.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Comment 1 Mamoru TASAKA 2008-11-16 09:51:08 UTC
Created attachment 323713 [details]
Xorg.0.log

Note: there is no xorg.conf

Comment 2 Mamoru TASAKA 2008-11-16 10:26:19 UTC
Once changing to iniscripts.
initscripts-8.86-1

This can be reproduced by the following:

- Reboot without rhgb option and with runlevel 3
- login to tty1 as root (not tty1 is used)
- on tty1, type $ init 5
- X launches, on tty1, not on tty7
- On tty1 (now gdm login session appears) type username
- Every time I type 'a' or so, annoying beep can be heared
- Now CTRL-ALT-F2
- login on tty2 as root, then type $ init 3
- Then CTRL-ALT-F1
- on tty1, _some garbage messages are now shown_
- on tty1, once type CTRL-C and again $ init 5
- This time X lauches on tty7

Comment 3 Mamoru TASAKA 2008-11-16 10:31:30 UTC
(In reply to comment #2)
> Once changing to iniscripts.
> initscripts-8.86-1
> 
> This can be reproduced by the following:
> 
> - Reboot without rhgb option and with runlevel 3
> - login to tty1 as root (not tty1 is used)

This is "now tty1 is used"...

Comment 4 Bill Nottingham 2008-11-17 15:37:40 UTC
If we're not going down the road of managing gdm force-tty behavior from the event files themselves, then plymouth needs to not write the magic file on runlevel 3.

Comment 5 Ray Strode [halfline] 2008-11-17 15:54:57 UTC
fix building as plymouth-0.6.0-0.2008.11.17.2

Comment 6 Mamoru TASAKA 2008-11-17 18:42:29 UTC
It seems that I am still seeing this issue with
kernel-2.6.27.5-109.fc10
plymouth-0.6.0-0.2008.11.17.2.fc10

Comment 7 Ray Strode [halfline] 2008-11-17 19:09:15 UTC
did you rebuild your initrd after installing the latest plymouth?

you can do that with 

/usr/libexec/plymouth/plymouth-update-initrd

(or reinstall your kernel)

Comment 8 Mamoru TASAKA 2008-11-17 19:29:12 UTC
(In reply to comment #7)
> did you rebuild your initrd after installing the latest plymouth?
> you can do that with 
> /usr/libexec/plymouth/plymouth-update-initrd
> (or reinstall your kernel)

Ah, thanks. Actually that works.

Comment 9 Mamoru TASAKA 2008-11-18 14:19:39 UTC
Closing, thank you.

Comment 10 Ray Strode [halfline] 2008-12-03 14:41:12 UTC
*** Bug 471504 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.