Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 471403 - Channel, package, list Installed Systems 500 error
Summary: Channel, package, list Installed Systems 500 error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: wes hayutin
URL: https://dhcp231-158.rdu.redhat.com/ne...
Whiteboard:
: 471265 (view as bug list)
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-13 14:54 UTC by wes hayutin
Modified: 2009-01-22 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:30:38 UTC


Attachments (Terms of Use)

Description wes hayutin 2008-11-13 14:54:44 UTC
Description of problem:

recreate..
1. register a system
2. go to channels, pick a package in the channel like bash
3. clicked installed systems, (should show a list of system installed with that version of bash.

500 ISE

The following exception occurred while executing this request:
 GET /network/software/packages/system_list.pxt?pid=12081 HTTP/1.1 (from browser)
 /network/software/packages/system_list.pxt (from Apache)

Date:
  Thu Nov 13 09:35:27 2008

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Cookie: rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|48EA534700000B47-A3A083F00003B8C[CE]; pxt-session-cookie=470x40c2a6fb25638623dd7a1ae22703bdc1
  Host: dhcp231-158.rdu.redhat.com
  Keep-Alive: 300
  Referer: https://dhcp231-158.rdu.redhat.com/rhn/software/packages/Details.do?pid=12081
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008091816 Red Hat/3.0.2-3.el5 Firefox/3.0.2

Form variables:
  pid => 12081

User Information:
  User admin (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: DBD::Oracle::db prepare failed: ORA-00904: "KS"."NAME": invalid identifier (DBD ERROR: error possibly near <*> indicator at char 453 in 'SELECT KSS.ID, KSS.KICKSTART_ID, KSS.KICKSTART_MODE, KSS.VIRTUALIZATION_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERVER_PROFILE_ID, KSS.ACTION_ID, KSS.LAST_FILE_REQUEST, KSS.PACKAGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CHAR(KSS.MODIFIED , 'YYYY-MM-DD HH24:MI:SS'), KSSS.ID, KSSS.NAME, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, <*>KS.NAME, KS.LABEL, KS.ACTIVE
FROM rhnKickstartSession KSS, rhnKickstartSessionState KSSS, rhnKSData KS
WHERE KSS.STATE_ID = KSSS.ID AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id = :sid) AND NOT EXISTS (SELECT 1 FROM rhnKickstartSessionState KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))
ORDER BY KSS.created DESC') [for Statement "SELECT KSS.ID, KSS.KICKSTART_ID, KSS.KICKSTART_MODE, KSS.VIRTUALIZATION_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERVER_PROFILE_ID, KSS.ACTION_ID, KSS.LAST_FILE_REQUEST, KSS.PACKAGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CHAR(KSS.MODIFIED , 'YYYY-MM-DD HH24:MI:SS'), KSSS.ID, KSSS.NAME, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, KS.NAME, KS.LABEL, KS.ACTIVE
FROM rhnKickstartSession KSS, rhnKickstartSessionState KSSS, rhnKSData KS
WHERE KSS.STATE_ID = KSSS.ID AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id = :sid) AND NOT EXISTS (SELECT 1 FROM rhnKickstartSessionState KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))
ORDER BY KSS.created DESC"]
  RHN::DB /var/www/lib/RHN/DB.pm 233 RHN::Exception::DB::throw
  RHN::DB::Kickstart::Session /var/www/lib/RHN/DB/Kickstart/Session.pm 139 RHN::DB::handle_error
  Sniglets::ListView::SystemList /var/www/lib/Sniglets/ListView/SystemList.pm 769 RHN::DB::Kickstart::Session::lookup
  Sniglets::ListView::List /var/www/lib/Sniglets/ListView/List.pm 1007 Sniglets::ListView::SystemList::row_callback
  Sniglets::Lists /var/www/lib/Sniglets/Lists.pm 128 Sniglets::ListView::List::render
  PXT::Parser /var/www/lib/PXT/Parser.pm 171 Sniglets::Lists::listview
  PXT::Parser /var/www/lib/PXT/Parser.pm 83 PXT::Parser::expand_tag
  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 631 PXT::Parser::expand_tags
  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 123 PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 123 (eval)
  main -e 0 PXT::ApacheHandler::handler
  main -e 0 (eval)

Offending Query: SELECT KSS.ID, KSS.KICKSTART_ID, KSS.KICKSTART_MODE, KSS.VIRTUALIZATION_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERVER_PROFILE_ID, KSS.ACTION_ID, KSS.LAST_FILE_REQUEST, KSS.PACKAGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CHAR(KSS.MODIFIED , 'YYYY-MM-DD HH24:MI:SS'), KSSS.ID, KSSS.NAME, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, KS.NAME, KS.LABEL, KS.ACTIVE
FROM rhnKickstartSession KSS, rhnKickstartSessionState KSSS, rhnKSData KS
WHERE KSS.STATE_ID = KSSS.ID AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id = :sid) AND NOT EXISTS (SELECT 1 FROM rhnKickstartSessionState KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))
ORDER BY KSS.created DESC

Comment 1 Jesus M. Rodriguez 2008-11-25 20:26:55 UTC
*** Bug 471265 has been marked as a duplicate of this bug. ***

Comment 2 Jesus M. Rodriguez 2008-12-04 20:45:51 UTC
fixed by bug #461162 
commit sha1: 25ec26a0878b84d5915e93c775ba79926ed4c3c7

Comment 3 wes hayutin 2008-12-16 14:41:47 UTC
verified
 bash-3.2-21.el5.i386.rpm Help Icon

    * Details
    * New Versions
    * Installed Systems
    * Target Systems

Systems with Package

This package is installed on the following systems.
  	1 - 1 of 1 (0 selected)   	   
	Errata 	Packages 	System 	Entitlement
	16 	25 	fjs-0-19.rhndev.redhat.com 	Management


Note You need to log in before you can comment on or make changes to this bug.