Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4714 - /tmp/.*-unix files must exist and be owned by root at all time
Summary: /tmp/.*-unix files must exist and be owned by root at all time
Keywords:
Status: CLOSED DUPLICATE of bug 3753
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-26 02:53 UTC by charles
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 19:22:03 UTC


Attachments (Terms of Use)

Description charles 1999-08-26 02:53:40 UTC
Since XFree86-3.3.3.1-tmpdir.patch was added to
XFree86-3.3.3.1-52.src.rpm, these directories should exist,
be owned by root.root, and have 1777 perms at all time:

	/tmp/.X11-unix
	/tmp/.XIM-unix
	/tmp/.font-unix
	/tmp/.ICE-unix
	/tmp/.Test-unix

Otherwise, for instance, one user won't be able to
properly use gnome if there is already a /tmp/.ICE-unix
not owned by root.  There will be one if anyone but
root last used gnome and there is not a permanent
root-owned /tmp/.ICE-unix.

They should probably be created by
	XFree86-libs-3.3.3.1-52.i386.rpm
and
	XFree86-devel-3.3.3.1-52.i386.rpm
since those include the pertinent libraries.  However,
they should be created with care in case someone is
using X at the time they are installed.

The /etc/cron.daily/tmpwatch may also be affected, as
well as tmpwatch itself since it should not destroy
these directories if owned by root even if they are
old...

/tmp/.font-unix is somewhat special because of the way
/etc/rc.d/init.d/xfs is written.  It could be excluded
from this, or not (for uniformity).


To reproduce the problem, just install 6.0 + all current
patches and, as a regular user, try to use gdm to start
a gnome session twice in a row.  (Don't apply the fix
to see the unwanted behavior!!)  Then look at the
~user/.xsession-errors file.

There may be a more elegant solution by reviewing how
XFree86-3.3.3.1-tmpdir.patch works.

Comment 1 Preston Brown 1999-08-31 19:22:59 UTC
*** This bug has been marked as a duplicate of 3753 ***


Note You need to log in before you can comment on or make changes to this bug.