Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 471265 - using ssm to delete systems, get 500 http error
Summary: using ssm to delete systems, get 500 http error
Keywords:
Status: CLOSED DUPLICATE of bug 471403
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: wes hayutin
URL: https://dhcp231-223.rdu.redhat.com/ne...
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-12 18:04 UTC by wes hayutin
Modified: 2008-11-25 20:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-25 20:26:55 UTC


Attachments (Terms of Use)

Description wes hayutin 2008-11-12 18:04:51 UTC
Description of problem:

register 1 or more profiles
select all systems
click manage
click delete systems

get 500 on webui

/var/log/http/error.log

[Wed Nov 12 17:59:05 2008] [notice] Digest: done
[Wed Nov 12 17:59:05 2008] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Wed Nov 12 17:59:05 2008] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Wed Nov 12 18:02:19 2008] [error] Execution of /var/www/html/network/systems/ssm/misc/delete_systems_conf.pxt failed at Wed Nov 12 18:02:19 2008: RHN::Exception: DBD::Orac
le::db prepare failed: ORA-00904: "KS"."NAME": invalid identifier (DBD ERROR: error possibly near <*> indicator at char 453 in 'SELECT KSS.ID, KSS.KICKSTART_ID, KSS.KICKSTA
RT_MODE, KSS.VIRTUALIZATION_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERVER_PROFILE_ID, KSS.ACTION_ID, KSS.LA
ST_FILE_REQUEST, KSS.PACKAGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CHAR(KSS.MODIFIED , 'YYYY-MM-DD HH24:M
I:SS'), KSSS.ID, KSSS.NAME, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, <*>KS.NAME, KS.LABEL, KS.ACTIVE\nFROM rhnKickstartSession KSS, rhnKickstartSessionState KSSS, rhnKSData KS\
nWHERE KSS.STATE_ID = KSSS.ID AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id = :sid) AND NOT EXISTS (SELECT 1 F
ROM rhnKickstartSessionState KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))\nORDER BY KSS.created DESC') [for Statement "SELECT K
SS.ID, KSS.KICKSTART_ID, KSS.KICKSTART_MODE, KSS.VIRTUALIZATION_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERV
ER_PROFILE_ID, KSS.ACTION_ID, KSS.LAST_FILE_REQUEST, KSS.PACKAGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CH
AR(KSS.MODIFIED , 'YYYY-MM-DD HH24:MI:SS'), KSSS.ID, KSSS.NAME, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, KS.NAME, KS.LABEL, KS.ACTIVE\nFROM rhnKickstartSession KSS, rhnKickstar
tSessionState KSSS, rhnKSData KS\nWHERE KSS.STATE_ID = KSSS.ID AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id =
 :sid) AND NOT EXISTS (SELECT 1 FROM rhnKickstartSessionState KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))\nORDER BY KSS.create
d DESC"]\n  RHN::DB /var/www/lib/RHN/DB.pm 233 RHN::Exception::DB::throw\n  RHN::DB::Kickstart::Session /var/www/lib/RHN/DB/Kickstart/Session.pm 139 RHN::DB::handle_error\n
  Sniglets::ListView::SystemList /var/www/lib/Sniglets/ListView/SystemList.pm 769 RHN::DB::Kickstart::Session::lookup\n  Sniglets::ListView::List /var/www/lib/Sniglets/List
View/List.pm 1007 Sniglets::ListView::SystemList::row_callback\n  Sniglets::Lists /var/www/lib/Sniglets/Lists.pm 128 Sniglets::ListView::List::render\n  PXT::Parser /var/ww
w/lib/PXT/Parser.pm 171 Sniglets::Lists::listview\n  PXT::Parser /var/www/lib/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.
pm 631 PXT::Parser::expand_tags\n  PXT::ApacheHandler /var/www/lib/PXT/ApacheHandler.pm 123 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /var/www/lib/PXT/Apache
Handler.pm 123 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)\n\nOffending Query: SELECT KSS.ID, KSS.KICKSTART_ID, KSS.KICKSTART_MODE, KSS.VIRTUALIZATI
ON_TYPE, KSS.KSTREE_ID, KSS.ORG_ID, KSS.SCHEDULER, KSS.OLD_SERVER_ID, KSS.NEW_SERVER_ID, KSS.STATE_ID, KSS.SERVER_PROFILE_ID, KSS.ACTION_ID, KSS.LAST_FILE_REQUEST, KSS.PACK
AGE_FETCH_COUNT, KSS.SYSTEM_RHN_HOST, KSS.DEPLOY_CONFIGS, TO_CHAR(KSS.CREATED , 'YYYY-MM-DD HH24:MI:SS'), TO_CHAR(KSS.MODIFIED , 'YYYY-MM-DD HH24:MI:SS'), KSSS.ID, KSSS.NAM
E, KSSS.LABEL, KSSS.DESCRIPTION, KS.ID, KS.NAME, KS.LABEL, KS.ACTIVE\nFROM rhnKickstartSession KSS, rhnKickstartSessionState KSSS, rhnKSData KS\nWHERE KSS.STATE_ID = KSSS.I
D AND KSS.KICKSTART_ID = KS.ID(+) AND KSS.org_id = :org_id AND (KSS.old_server_id = :sid OR KSS.new_server_id = :sid) AND NOT EXISTS (SELECT 1 FROM rhnKickstartSessionState
 KSSS WHERE KSSS.id = KSS.state_id AND (KSSS.label = 'failed' or KSSS.label = 'complete'))\nORDER BY KSS.created DESC

Comment 1 Jesus M. Rodriguez 2008-11-25 20:26:55 UTC

*** This bug has been marked as a duplicate of bug 471403 ***


Note You need to log in before you can comment on or make changes to this bug.