Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 471199 - delete_server performance improvement
Summary: delete_server performance improvement
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.3
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-12 10:18 UTC by Michael Mráka
Modified: 2009-01-22 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:30:27 UTC


Attachments (Terms of Use)

Description Michael Mráka 2008-11-12 10:18:49 UTC
+++ This bug was initially created as a clone of Bug #471198 +++

The reason we're making this change, is that the
current delete_server_bulk (which is only invoked from the SSM
delete-servers page) is running as One Gigantic Transaction.  THis
is...bad.  In a lot of ways, really.  You'd be *amazed* at how many
tables get locked, for how long, when this damn thing runs on a large DB
with many servers involved.

Large satellites are going to have the same issues.  if I'd been
thinking, I'd have poked y'all earlier.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michael Mráka 2008-11-12 13:16:49 UTC
Changed in git

commit 97f2b7f643064c51c2d6b4860ae48ca82983ba3a
    471199 - added delete_server and delete_server_bulk to upgrades
...
commit 3eeedaeb12b1a9657bfd668eb35519ec2fc0a31e
    471199 - replace for...delete with forall...delete

Comment 2 Michael Mráka 2008-11-12 13:35:33 UTC
Package spacewalk-schema-0.4.2-1.

Comment 3 Miroslav Suchý 2009-01-15 12:29:09 UTC
we are still able to delete servers, which is good.
Dunno how to test the speed for huge amount of server...
VERIFIED


Note You need to log in before you can comment on or make changes to this bug.