Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 470149 - Configuration Files: "File Is Too Large to Edit" should display MAX_EDITABLE_SIZE instead of CONFIG_REVISION_MAX_SIZE
Summary: Configuration Files: "File Is Too Large to Edit" should display MAX_EDITABLE_...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Matthews
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-05 22:42 UTC by John Matthews
Modified: 2009-01-22 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:30:18 UTC


Attachments (Terms of Use)

Description John Matthews 2008-11-05 22:42:35 UTC
From satellite bug 433378


Description of problem:

Configuration files cannot be larger than 32k to be edited in Satellite 5.0

How reproducible:

Every time

Steps to Reproduce:

1) Upload a configuration file larger than 32k (for example, 32.5k)
2) Try to edit configuration file

Actual results:

Satellite complains that the file is to large to be edited and that it must be
less than 128k to be edited. 

Expected results:

No error message, either 32k or 128k should be the upper limit for editable
configuration file. The message in this form is highly misleading, to say the
least.

Comment 1 John Matthews 2008-11-05 22:45:02 UTC
Fixed in commit:
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=37e91c989cb1656c71ff5e543cf572d44a46560a


WebUI now displays:

File Is Too Large to Edit
You can't edit this file here because it is too large (files must be less than 32 KB to be editable in this form). You can, however, download this file, edit it locally on your computer, and upload your changes here.


Note You need to log in before you can comment on or make changes to this bug.