Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 469903 - Search server "cleanindex" option broken
Summary: Search server "cleanindex" option broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: John Matthews
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-11-04 17:23 UTC by John Matthews
Modified: 2009-01-22 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:30:11 UTC


Attachments (Terms of Use)

Description John Matthews 2008-11-04 17:23:52 UTC
Description of problem:

Run "/sbin/service rhn-search cleanindex" and you will see an error because the Oracle JDBC jar is not in the CLASSPATH.


Version-Release number of selected component (if applicable):
spacewalk-search-0.3.4-1.el5.sw

How reproducible:
always

Steps to Reproduce:
1./sbin/service rhn-search cleanindex
2.
3.

Comment 2 John Matthews 2008-11-05 17:30:15 UTC
This got fixed in this build:
spacewalk-search-0.3.5-1.el5.sw.noarch.rpm

Comment 3 Jesus M. Rodriguez 2009-01-15 04:18:15 UTC
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastErrata
09/01/14 23:14:07 INFO search.DeleteIndexes: Attempting to delete /usr/share/rhn/search/indexes/errata
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastPackage
09/01/14 23:14:07 INFO search.DeleteIndexes: Attempting to delete /usr/share/rhn/search/indexes/package
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastServer
09/01/14 23:14:07 INFO search.DeleteIndexes: Attempting to delete /usr/share/rhn/search/indexes/server
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastHardwareDevice
09/01/14 23:14:07 INFO search.DeleteIndexes: Attempting to delete /usr/share/rhn/search/indexes/hwdevice
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastSnapshotTag
09/01/14 23:14:07 INFO search.DeleteIndexes: Running query: deleteLastServerCustomInfo
09/01/14 23:14:07 INFO search.DeleteIndexes: Index files have been deleted and database has been cleaned up, ready to reindex


BEFORE:
ls indexes/
docs  errata  hwdevice  package  server

AFTER:
ls indexes/
docs

Docs are *NOT* regenerated so they were correctly left behind.


Note You need to log in before you can comment on or make changes to this bug.