Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 468999 - Stop Attempting Manual Yum, Pirut, and Yum-rhn-plugin Upgrades in Kickstart Post
Summary: Stop Attempting Manual Yum, Pirut, and Yum-rhn-plugin Upgrades in Kickstart Post
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-10-29 12:36 UTC by Devan Goodwin
Modified: 2009-02-24 19:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-24 19:28:55 UTC


Attachments (Terms of Use)

Description Devan Goodwin 2008-10-29 12:36:40 UTC
Description of problem:

Satellite kickstart profiles attempt to automatically update yum, pirut, and yum-rhn-plugin in a %post script using wget and rpm. Due to constantly changing dependencies this code was rapidly proving to be an unmaintainable solution and should be removed.

This is mostly a problem for Satellite installations installing RHEL 5.0 when RHEL 5.2 is available and has less relevance to Spacewalk.


Steps to Reproduce:
1. Create a RHEL 5 or CentOS 5 kickstart profile.
2. View kickstart file.

  
Actual results:

Profile attempts to download the latest version of these packages with wget and rpm freshen them.

Expected results:

Stop grabbing these packages and leave the installed versions alone.

Comment 1 Devan Goodwin 2008-10-29 12:37:16 UTC
Fix applied in spacewalk git: 77a369d3709360f27c0c1213c36f1ca9699ad2cc


Note You need to log in before you can comment on or make changes to this bug.