Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 468831 - gstreamer-java not run on fedora ppc
Summary: gstreamer-java not run on fedora ppc
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-ExcludeArch-ppc64, F-ExcludeArch-ppc64 PPCTracker F-ExcludeArch-ppc
TreeView+ depends on / blocked
 
Reported: 2008-10-28 10:16 UTC by Levente Farkas
Modified: 2018-04-11 17:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 14:49:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Icedtea Bugzilla 268 None None None Never

Description Levente Farkas 2008-10-28 10:16:36 UTC
the gstreamer-java not build on linux-ppc. the relevant build log is here, where you can see that the unit test fails on ppc:
http://koji.fedoraproject.org/koji/getfile?taskID=905786&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=905792&name=build.log
it seems it's almost certainly an OpenJDK bug (specifically in the zero-assembler
Hotspot port).

Comment 1 Levente Farkas 2008-10-28 11:27:18 UTC
external references:
http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=190

Comment 2 Gary Benson 2008-11-07 08:52:06 UTC
Andrew, this is the bug caused by the broken shift, right?

Comment 3 Andrew Haley 2008-11-07 10:44:48 UTC
Sorry, I have no idea.  We'd have to try to duplicate the bug.

Comment 4 Gary Benson 2008-11-07 11:17:36 UTC
Was the broken shift one the JSR166 testcase one then?

Comment 5 Andrew Haley 2008-11-07 11:29:23 UTC
Yes, the broken shift did cause the JSR166 test failure.

Comment 6 Matěj Cepl 2008-11-28 17:37:57 UTC
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever
they want to do with it.

Comment 7 Gary Benson 2008-12-01 11:30:26 UTC
The logfiles seem to have been deleted.  Can they be recreated or otherwise uploaded?

Comment 8 Levente Farkas 2008-12-01 12:58:59 UTC
wget http://koji.fedoraproject.org/packages/gstreamer-java/1.0/1.fc10/src/gstreamer-java-1.0-1.fc10.src.rpm
koji build --scratch dist-f10 gstreamer-java-1.0-1.fc10.src.rpm
and try to put to any of the ppc builder
or even best to try to build on a ppc:
rpmbuild --rebuild gstreamer-java-1.0-1.fc10.src.rpm
:-)

Comment 9 Gary Benson 2008-12-01 13:19:35 UTC
I'm going to track this as http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=268

Comment 10 Levente Farkas 2008-12-01 13:53:58 UTC
anyway i create a new build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=966032

Comment 11 Gary Benson 2008-12-01 14:10:32 UTC
How do I get the srpm out of that?

Comment 12 Levente Farkas 2008-12-01 14:19:55 UTC
from the bad build you can't get, but from a good build like the above
http://koji.fedoraproject.org/packages/gstreamer-java/1.0/1.fc10/src/gstreamer-java-1.0-1.fc10.src.rpm
you can get:-)

Comment 13 Gary Benson 2008-12-01 14:28:49 UTC
Got it, thanks :)

Comment 14 Rafael Fonseca 2015-08-13 13:05:06 UTC
2008... is this still valid?

Comment 15 Andrew John Hughes 2015-08-13 15:10:53 UTC
java-1.6.0-openjdk hasn't been part of Fedora for a long time either.

Are PPC packages still being built for Fedora? If so, where?

Comment 17 Dan Horák 2015-08-13 16:13:55 UTC
Guess this should be closed as gstreamer-java is retired in mainline Fedora.


Note You need to log in before you can comment on or make changes to this bug.