Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 466804 - Rhythythmbox does not display cover art.
Summary: Rhythythmbox does not display cover art.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pygobject2
Version: rawhide
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10DesktopTarget
TreeView+ depends on / blocked
 
Reported: 2008-10-13 18:07 UTC by Dawid Zamirski
Modified: 2008-10-21 18:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-21 18:32:25 UTC


Attachments (Terms of Use)
rhythmbox -d (deleted)
2008-10-15 02:59 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2008-10-13 18:07:45 UTC
Description of problem:
Rhythmbox does not display cover art after installing F10 Beta (clean install no upgrade). Updating to latest rawhide does not fix the problem.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.6-13.5966.fc10.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install F10 Beta and optionally update the system to be in sync with rawhide.
2. Enable the Cover Art plugin in rhythmbox.
3. Play some music (different bands - well tagged) and see no cover displayed.
  
Actual results:
The cover art is not displayed.

Expected results:
Show cover art of currently played album.

Additional info:
Rhythmbox in F9 x86_64 was working ok.

Comment 1 Bastien Nocera 2008-10-14 13:17:46 UTC
Please attach the output of "rhythmbox -d" when playing those songs.

Comment 2 Matthias Clasen 2008-10-14 14:03:37 UTC
The only cover related things I see in the output are 

(09:58:33) [0x83ed478] [rb_plugins_engine_load_cb] rb-plugins-engine.c:299: Plugin Cover art loaded


and then later, when I start to play an album:

(09:58:39) [0x83ed478] [LocalCoverArtSearch.search] /usr/lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.py:145: searching for local art for file:///home/mclasen/Music/Al%20Stewart/Rhymes%20In%20Rooms%20(Live)/11%20-%20Year%20Of%20The%20Cat.ogg


But no cover is displayed

Comment 3 Dawid Zamirski 2008-10-15 02:59:06 UTC
Created attachment 320382 [details]
rhythmbox -d

I cut out the rhythmdb related stuff because the log would be way too large with lots of irrelevant info.

Comment 4 Bastien Nocera 2008-10-21 18:32:25 UTC
Gah!

Spent an afternoon to find out it wasn't Rhythmbox' fault.

Fixed in pygobject2-2.15.4-3.fc10 (the files loaded from the network were truncated by the Python bindings).


Note You need to log in before you can comment on or make changes to this bug.