Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 466629 - gnome-display-properties multihead changes cause ATI problems
Summary: gnome-display-properties multihead changes cause ATI problems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 10
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10DesktopTarget
TreeView+ depends on / blocked
 
Reported: 2008-10-11 20:41 UTC by Gordon Messmer
Modified: 2014-06-18 09:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-10 07:37:24 UTC


Attachments (Terms of Use)
monitors.xml resulting from the working steps (deleted)
2008-10-11 20:42 UTC, Gordon Messmer
no flags Details
xrandr output resulting from the workign steps (deleted)
2008-10-11 20:42 UTC, Gordon Messmer
no flags Details
monitors.xml resulting from the first half of the non-working steps (deleted)
2008-10-11 20:43 UTC, Gordon Messmer
no flags Details
xrandr output resulting from the first half of the non-working steps (deleted)
2008-10-11 20:43 UTC, Gordon Messmer
no flags Details
monitors.xml resulting from the final half of the non-working steps (deleted)
2008-10-11 20:44 UTC, Gordon Messmer
no flags Details
xrandr output resulting from the final half of the non-working steps (deleted)
2008-10-11 20:44 UTC, Gordon Messmer
no flags Details

Description Gordon Messmer 2008-10-11 20:41:24 UTC
Description of problem:
This is a bit of a weird issue.  I'm using an ATI video card with dual outputs.  Certain use patterns of gnome-display-properties cause things to break.

First, I can produce the desired results by following these steps:
1. run gnome-display-properties
2. uncheck "Mirror Screens"
3. move the blue screen icon to the right and click Apply.

By following those steps, I move the DVI-0 output to the right, producing a wide multihead desktop.

However, if I don't know that I'm supposed to do that (perhaps because the outputs aren't labelled in g-d-p) I might follow these steps instead:
1. run gnome-display-properties
2. uncheck "Mirror Screens"
3. move the blue screen icon to the left and click Apply.
   - this makes the DVI-0 output the "left" desktop area.  
   - DVI-0 is now represented by a green icon instead of its 
     original blue, which is odd.
   - I actually wanted the DVI-0 output to be the right area of the desktop.
     I figure out that the left desktop area is on the right physical monitor,
     so I want to move the left monitor icon to the right, in order that it
     will display the right desktop area.
4. move the green icon (DVI-0, displaying the left desktop area) to the right
   of the blue icon.
   - this makes the DVI-0 the "right" monitor.  It is represented by the 
     a blue icon again.
   - both physical displays are mirrored, with the contents that should be on
     the DVI-0 output

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-7.fc10.x86_64
xorg-x11-drv-ati-6.9.0-25.fc10.x86_64
xorg-x11-server-Xorg-1.5.2-2.fc10.x86_64


How reproducible:
Always

Actual results:
The physical displays are mirrored, even though they're configured to be a wide multihead desktop.

Comment 1 Gordon Messmer 2008-10-11 20:42:12 UTC
Created attachment 320114 [details]
monitors.xml resulting from the working steps

Comment 2 Gordon Messmer 2008-10-11 20:42:37 UTC
Created attachment 320115 [details]
xrandr output resulting from the workign steps

Comment 3 Gordon Messmer 2008-10-11 20:43:17 UTC
Created attachment 320116 [details]
monitors.xml resulting from the first half of the non-working steps

Comment 4 Gordon Messmer 2008-10-11 20:43:48 UTC
Created attachment 320117 [details]
xrandr output resulting from the first half of the non-working steps

Comment 5 Gordon Messmer 2008-10-11 20:44:14 UTC
Created attachment 320118 [details]
monitors.xml resulting from the final half of the non-working steps

Comment 6 Gordon Messmer 2008-10-11 20:44:35 UTC
Created attachment 320119 [details]
xrandr output resulting from the final half of the non-working steps

Comment 7 Bug Zapper 2008-11-26 03:47:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.