Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 465096 - FTBFS pyclutter-0.6.2-2.fc9
Summary: FTBFS pyclutter-0.6.2-2.fc9
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pyclutter
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Allisson Azevedo
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Depends On:
Blocks: F10FTBFS
TreeView+ depends on / blocked
 
Reported: 2008-10-01 16:40 UTC by FTBFS
Modified: 2008-10-09 06:33 UTC (History)
2 users (show)

Fixed In Version: 0.1.20081008r3353.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-09 06:33:48 UTC


Attachments (Terms of Use)
root.log (deleted)
2008-10-01 16:40 UTC, FTBFS
no flags Details
build.log (deleted)
2008-10-01 16:41 UTC, FTBFS
no flags Details
mock.log (deleted)
2008-10-01 16:41 UTC, FTBFS
no flags Details
root.log (deleted)
2008-10-01 16:41 UTC, FTBFS
no flags Details
build.log (deleted)
2008-10-01 16:41 UTC, FTBFS
no flags Details
mock.log (deleted)
2008-10-01 16:41 UTC, FTBFS
no flags Details

Description FTBFS 2008-10-01 16:40:55 UTC
pyclutter-0.6.2-2.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.

Comment 1 FTBFS 2008-10-01 16:40:59 UTC
Created attachment 319005 [details]
root.log

root.log for i386

Comment 2 FTBFS 2008-10-01 16:41:00 UTC
Created attachment 319006 [details]
build.log

build.log for i386

Comment 3 FTBFS 2008-10-01 16:41:01 UTC
Created attachment 319007 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2008-10-01 16:41:03 UTC
Created attachment 319008 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2008-10-01 16:41:04 UTC
Created attachment 319009 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2008-10-01 16:41:05 UTC
Created attachment 319010 [details]
mock.log

mock.log for x86_64

Comment 7 Alex Lancaster 2008-10-05 10:32:19 UTC
Please address this package ASAP, it continues to cause broken dep reports in rawhide for > 1 month:

        pyclutter-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
        pyclutter-cairo-0.6.2-2.fc9.i386 requires libclutter-cairo-0.6.so.0
        pyclutter-cairo-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
        pyclutter-gst-0.6.2-2.fc9.i386 requires libclutter-gst-0.6.so.0
        pyclutter-gst-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
        pyclutter-gtk-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
        pyclutter-gtk-0.6.2-2.fc9.i386 requires libclutter-gtk-0.6.so.0

Comment 8 Alex Lancaster 2008-10-05 10:33:10 UTC
See also query on f-d-l:

http://www.redhat.com/archives/fedora-devel-list/2008-October/msg00020.html

Comment 9 Alex Lancaster 2008-10-07 03:42:31 UTC
Ping?  This needs to be looked at ASAP.  Can you please let us know why you marked it as "dead.package" in CVS without fully following through on the full retirement procedure?

If you just wanted to orphan it because it didn't build and you don't want to deal with it anymore you should just do that in packagedb.

Thanks.

Comment 10 Allisson Azevedo 2008-10-07 10:18:55 UTC
Hi Alex,

This package still in version 0.6.x, there is not upstream version compatible with new clutter 0.8.x series.

Comment 11 Alex Lancaster 2008-10-07 11:43:16 UTC
(In reply to comment #10)
> Hi Alex,
> 
> This package still in version 0.6.x, there is not upstream version compatible
> with new clutter 0.8.x series.

Thanks for the update.  Will there ever be an pyclutter compatible with clutter 0.8.x?  i.e. is this a temporary state, or is upstream permanently dead?   Will something else succeed it?

If it is only temporary, we might think about introducing a compat-clutter06 compatibility package for users of pyclutter.  If pyclutter is still useful to users (and especially if it used by other packages), we should consider providing  them, see:

https://fedoraproject.org/wiki/JeremyKatz/DraftCompatPackages

Comment 12 Alex Lancaster 2008-10-07 11:50:09 UTC
I had a look at the mailing lists and it looks like somebody still is working on pyclutter (albeit slowly):

http://lists.o-hand.com/clutter/1525.html

"so I guess I'm really asking for help on this release of PyClutter, or
0.8.0 will be delayed until I get enough time either to figure out the
bugs or to start the bindings from scratch and see where they fail.

ciao,
 Emmanuele. "

which was in July 2008.  So it seems premature to completely remove it from the distribution.

Comment 13 Alex Lancaster 2008-10-07 11:53:16 UTC
And an even more recent thread from August indicates progress:

http://lists.o-hand.com/clutter/1653.html

Perhaps you could package the SVN version of pyclutter 0.8.x for the moment.  That would be better than removing it since it seems that it will ultimately be released.

Comment 14 Alex Lancaster 2008-10-09 06:33:48 UTC
I took the liberty of packaging up an SVN snapshot r3353 of 0.8.0 and rebuilding for rawhide to avoid having to remove the package:

https://koji.fedoraproject.org/koji/buildinfo?buildID=65798

It looks like there will be a 0.8.0 version along shortly.


Note You need to log in before you can comment on or make changes to this bug.