Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 465069 - FTBFS zsh-4.3.4-8.fc9
Summary: FTBFS zsh-4.3.4-8.fc9
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: zsh
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
: 473738 (view as bug list)
Depends On:
Blocks: F10FTBFS
TreeView+ depends on / blocked
 
Reported: 2008-10-01 16:36 UTC by FTBFS
Modified: 2009-05-17 21:37 UTC (History)
4 users (show)

Fixed In Version: zsh-4.3.9-4.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-17 21:37:11 UTC


Attachments (Terms of Use)
root.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details
build.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details
mock.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details
root.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details
build.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details
mock.log (deleted)
2008-10-01 16:36 UTC, FTBFS
no flags Details

Description FTBFS 2008-10-01 16:36:02 UTC
zsh-4.3.4-8.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.

Comment 1 FTBFS 2008-10-01 16:36:05 UTC
Created attachment 318857 [details]
root.log

root.log for i386

Comment 2 FTBFS 2008-10-01 16:36:07 UTC
Created attachment 318858 [details]
build.log

build.log for i386

Comment 3 FTBFS 2008-10-01 16:36:08 UTC
Created attachment 318859 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2008-10-01 16:36:09 UTC
Created attachment 318860 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2008-10-01 16:36:10 UTC
Created attachment 318861 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2008-10-01 16:36:11 UTC
Created attachment 318862 [details]
mock.log

mock.log for x86_64

Comment 7 James Antill 2008-10-09 16:55:21 UTC
So the problem here is that I tried to put a new version of zsh into rawhide, but it failed due to upstream bugs ... is there something I should do, apart from waiting for a new upstream release to try instead?

Comment 8 Matt Domsch 2008-10-09 18:12:03 UTC
yes, you'll want to either fix the upstream project's bugs and add a Patch0:, or revert to an earlier bug-free version; or wait for upstream to release a fix or new version, and rebuild accordingly.

Comment 9 Bug Zapper 2008-11-26 03:23:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 James Antill 2008-12-20 19:27:49 UTC
*** Bug 473738 has been marked as a duplicate of this bug. ***

Comment 11 James Antill 2008-12-20 19:33:59 UTC
 This is tracked in: https://bugzilla.redhat.com/show_bug.cgi?id=460043
 ... upstream's 4.3.9 still doesn't fix the problem, so we are still screwed.

Comment 12 Milos Jakubicek 2009-05-17 21:37:11 UTC
Built for F11 -> closing.


Note You need to log in before you can comment on or make changes to this bug.