Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 464757 - Review Request: openssl-tpm-engine - OpenSSL engine for TSS API
Summary: Review Request: openssl-tpm-engine - OpenSSL engine for TSS API
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rajiv Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2008-09-30 10:21 UTC by David Woodhouse
Modified: 2012-06-29 22:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-29 22:01:56 UTC


Attachments (Terms of Use)

Description David Woodhouse 2008-09-30 10:21:58 UTC
Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-1.fc10.src.rpm
Description: This package provides an OpenSSL "engine" which lets OpenSSL handle keys stored in a TPM.

Comment 1 David Woodhouse 2008-09-30 10:25:57 UTC
I am probably a poor choice of maintainer for this package. Does anyone with more clue want it?

Comment 2 David Woodhouse 2008-09-30 13:32:43 UTC
New patch to store TSS key 'blobs' in a text file rather than in a separate binary-only file, so that users can have a single '.pem' file with their identity, as they can without the TPM.

If the trousers-tech list ever accepts my subscription attempt, I'll post it there.

http://david.woodhou.se/openssl-tpm-engine-privkey-pem.patch

Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-2.fc10.src.rpm

Comment 3 Rajiv Andrade 2008-10-01 14:04:03 UTC
Hi David,

I can't see you subscription request to trousers-tech neither a post from you awaiting approval, did I miss something?

Thanks

Comment 4 David Woodhouse 2008-10-01 15:33:35 UTC
I've just tried again, at 
https://lists.sourceforge.net/lists/subscribe/trousers-tech

I haven't tried posting there, but I did post to trousers-users on the 25th of September, subject 'TPM support in my application'. That doesn't appear in the archives either (but if you find it, don't bother; I have patches for most of it now).

Would you like to own the openssl-tpm-engine package? I could only be a package-monkey for it, not a real maintainer.

Comment 5 David Woodhouse 2008-10-03 10:32:34 UTC
Fixed tspi library handling so it doesn't depend on trousers-devel, but only on trousers, and that dependency is picked up properly by RPM.

Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-4.fc9.src.rpm

Comment 6 Jason Tibbitts 2009-07-14 22:45:51 UTC
Another old one; unfortunately it fails to build:

+ aclocal
+ automake --add-missing -c --foreign
Makefile.am:5: Libtool library used but `LIBTOOL' is undefined
Makefile.am:5:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
Makefile.am:5:   to `configure.in' and run `aclocal' and `autoconf' again.
Makefile.am:5:   If `AC_PROG_LIBTOOL' is in `configure.in', make sure
Makefile.am:5:   its definition is in aclocal's search path.
error: Bad exit status from /var/tmp/rpm-tmp.9uMxE4 (%build)

Comment 7 Thomas Spura 2009-10-23 20:55:51 UTC
Here is a different build error:

./libtool: line 775: X--tag=CC: command not found
./libtool: line 808: libtool: ignoring unknown tag : command not found
./libtool: line 775: X--mode=compile: command not found
./libtool: line 925: *** Warning: inferring the mode of operation is deprecated.: command not found
./libtool: line 926: *** Future versions of Libtool will require --mode=MODE be specified.: command not found

and many more...

David, are you still working on this?

Comment 8 David Woodhouse 2009-10-23 22:56:11 UTC
Ew, libtool. I think I'll rewrite it to use proper Makefiles instead. Yes, I'd still like this to go in.

Comment 9 Jason Tibbitts 2009-11-08 01:27:24 UTC
Indicating that this doesn't build; please clear the whiteboard when that's been fixed.

Comment 10 Jason Tibbitts 2010-01-25 23:15:01 UTC
This is still marked as not building.  Can we fix that up or close this ticket out?

Comment 11 David Woodhouse 2010-01-26 05:28:53 UTC
The autohell problems are the least of my worries right now -- when I make it build against OpenSSL 1.0.0 it doesn't _work_ either.

http://www.mail-archive.com/trousers-tech@lists.sourceforge.net/msg00024.html

I'm working on it, but slowly.

Comment 12 Jason Tibbitts 2010-11-02 21:21:10 UTC
And, after a few days short of a year, still marked as not building.  I saw that something happened back in April but I don't know if there's still any desire to get this package in.


Note You need to log in before you can comment on or make changes to this bug.