Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 463780 - Add new logical volume raises exception
Summary: Add new logical volume raises exception
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Alexander Todorov
URL:
Whiteboard:
: 463843 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-09-24 17:35 UTC by Radek Vykydal
Modified: 2009-01-20 21:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:37:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
traceback file (deleted)
2008-09-24 17:35 UTC, Radek Vykydal
no flags Details
patch with fix (deleted)
2008-09-25 10:56 UTC, Radek Vykydal
no flags Details | Diff
updated patch with fix (deleted)
2008-09-25 11:23 UTC, Radek Vykydal
no flags Details | Diff
updated fix (deleted)
2008-09-30 08:55 UTC, Radek Vykydal
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0164 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-01-20 16:05:24 UTC

Description Radek Vykydal 2008-09-24 17:35:00 UTC
Created attachment 317608 [details]
traceback file

Description of problem:
In partition editor after "Remove all partitions on selected
drives and create default layout", trying to add a logical
partition to VolGroup00 raises exception. 

Version-Release number of selected component (if applicable):
tree: rhel5 20080919 nightly Server i386
anaconda: 11.1.2.126-1

How reproducible:
always

Steps to Reproduce:
1. in partitioning select
"Remove all partitions on selected drives and create default layout"
and check "Review and modify partitioning layout", go "Next"
2. in partittion editor edit LogVol00 partition
3. in "Edit LVM Volume Group" dialog delete LogVol00 partition
4. in "Edit LVM Volume Group" dialog click "Add"
  
Actual results:
Exception raised
Traceback (most recent call first):
  File "/usr/lib/anaconda/partRequests.py", line 981, in getActualSize
    retval = lvm.clampLVSizeRequest(retval, vgreq.pesize)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 445, in editLogicalVolume
    sizeEntry.set_text("%Ld" % (logrequest.getActualSize(self.partitions, self.diskset),))
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 775, in addLogicalVolumeCB
    self.editLogicalVolume(request, isNew = 1)
AttributeError: 'NoneType' object has no attribute 'pesize'


Expected results:
Dialog for adding should appear


Additional info:
traceback attached

Comment 1 RHEL Product and Program Management 2008-09-24 19:15:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Radek Vykydal 2008-09-25 10:56:54 UTC
Created attachment 317675 [details]
patch with fix

Seems like to be caused by commit 4aa9ca1c35b867fa5a4d94c41591700ca7ab5edb,
(bug #415871).
The patch should solve this bug while keeping what was intended with patch
for #415871 in.

Comment 3 Radek Vykydal 2008-09-25 11:02:06 UTC
(In reply to comment #2)

> ............................ while keeping what was intended with patch
> for #415871 in.

Joel, could you review attached patch that wrt ^^^^?

Comment 4 Radek Vykydal 2008-09-25 11:23:24 UTC
Created attachment 317677 [details]
updated patch with fix

Comment 5 Joel Andres Granados 2008-09-25 12:19:34 UTC
To consider the "round down patch, 4aa9ca1c35b867fa5a4d94c41591700ca7ab5edb" only for the volumes that are described with percent seems OK to me.

I'd go ahead and commit it.

Comment 6 Radek Vykydal 2008-09-25 13:34:57 UTC
*** Bug 463843 has been marked as a duplicate of this bug. ***

Comment 7 Radek Vykydal 2008-09-25 16:54:38 UTC
The patch from comment #4 doesn't work.
Things seem pretty more complicated.

Comment 8 Radek Vykydal 2008-09-30 08:55:57 UTC
Created attachment 318049 [details]
updated fix

should fix the bug, also tested against reproducer of original bug #415871

Comment 9 Radek Vykydal 2008-09-30 15:12:00 UTC
Fixed with commit 08233b0c42f8b453ff7d8bde03c9adc57d92d7ed,
should go into anaconda-11.1.2.133.

Comment 14 errata-xmlrpc 2009-01-20 21:37:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html


Note You need to log in before you can comment on or make changes to this bug.