Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4620 - /etc/sysconfig/network-scripts/ifup not calling pump correctly when a hostname is required to be sent to the dhcp server
Summary: /etc/sysconfig/network-scripts/ifup not calling pump correctly when a hostnam...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-20 03:25 UTC by jar
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-20 15:35:29 UTC


Attachments (Terms of Use)

Description jar 1999-08-20 03:25:20 UTC
If you have configured a Redhat 6 machine to use DHCP and
you are required to send the DHCP server a hostname there
is no provision in /etc/sysconfig/network-scripts/ifup do
do so.

My work around was to replace, in ifup:

      if /sbin/pump -i $DEVICE ; then

with

      if /sbin/pump -h `hostname` -i $DEVICE ; then

Very may DHCP sites would be set up so this is required, I
believe.

regards,
john

Comment 1 Bill Nottingham 1999-08-20 15:35:59 UTC
In initscripts-4.32 (will be in next rawhide), just set
the 'DHCP_HOSTNAME' variable in /etc/sysconfig/ifcfg-<device>,
and ifup will pass this to pump.


Note You need to log in before you can comment on or make changes to this bug.