Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 461170 - Search Server: nonsensical things return results
Summary: Search Server: nonsensical things return results
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Matthews
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-09-04 17:30 UTC by Justin Sherrill
Modified: 2009-01-22 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:54 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2008-09-04 17:30:53 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. type something like   "837248723847893" or "jksdflsdjflwoinlv" into the search box
2. hit search
3. 
  
Actual results:
get results

Expected results:
shouldn't get results

Additional info:
maybe the score on the search results needs to be filtered more.

Comment 1 John Matthews 2008-12-10 18:44:42 UTC
The issue is that we had logic in the search server to return the 10 best hits.  For the case of a system search with say "jksdflsdjflwoinlv" in the system name.  The search string would be broken up into a series of NGrams (permutations of all the letters) and that would be searched and ranked.  We'd get back scores that were very low and return the highest scoring 10.    

Now I've add in a check that if the score is below a configurable threshold value we will not return the results.  This check is only for system search, for other searches we still return the first 10 matches at a minimum.

search.system_score_threshold=.10

This change was introduced in spacewalk 0.3.

Comment 2 Jesus M. Rodriguez 2009-01-15 04:10:55 UTC
searching for 837248723847893 or jksdflsdjflwoinlv, resulted in no systems found.


Note You need to log in before you can comment on or make changes to this bug.