Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 460663 - quit tomboy -> Segmentation fault
Summary: quit tomboy -> Segmentation fault
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tomboy
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 467294 467298
Blocks: F10DesktopTarget
TreeView+ depends on / blocked
 
Reported: 2008-08-29 14:59 UTC by sangu
Modified: 2008-10-27 23:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-27 23:23:17 UTC


Attachments (Terms of Use)
patch to work around the bug (deleted)
2008-10-14 19:56 UTC, Dan Winship
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 528476 None None None Never

Description sangu 2008-08-29 14:59:35 UTC
Description of problem:
quit tomboy -> Segmentation fault

$ dmesg | grep tomboy
tomboy[3595]: segfault at 3848198 ip 03848198 sp bff58750 error 4 in libgnomeprintui-2-2.so.0.1.0[3b24000+41000]
tomboy[3730]: segfault at 2102198 ip 02102198 sp bf8fb038 error 4 in libpanel-applet-2.so.0.2.42[2110000+d000]
tomboy[3877]: segfault at 73b2198 ip 073b2198 sp bfff1978 error 4 in libkrb5.so.3.3[7412000+9c000]
tomboy[3949]: segfault at 79c0198 ip 079c0198 sp bfd29dc4 error 4 in libgnomeprint-2-2.so.0.1.0[7acb000+70000]
tomboy[3905]: segfault at 3aed198 ip 03aed198 sp bf8a90e0 error 4 in libdbus-1.so.3.4.0[3db2000+3f000]
tomboy[3959]: segfault at 1f10198 ip 01f10198 sp bfefe078 error 4 in libvorbis.so.0.4.0[2057000+1d000]
tomboy[4062]: segfault at 44c4198 ip 044c4198 sp bfa1a2c4 error 4 in libclearlooks.so[4648000+28000]
tomboy[4050]: segfault at 76a7198 ip 076a7198 sp bf9fe138 error 4 in libgmodule-2.0.so.0.1707.0[7a91000+3000]
tomboy[4134]: segfault at 4b633d0 ip 04b633d0 sp bf8a3934 error 4 in libglibsharpglue-2.so[51df000+2000]
tomboy[4114]: segfault at 1120198 ip 01120198 sp bff4d740 error 4 in libglibsharpglue-2.so[112d000+2000]
tomboy[4157]: segfault at 99f73d0 ip 099f73d0 sp bfe13788 error 4


Version-Release number of selected component (if applicable):
0.11.3-1.fc10

How reproducible:
always

Steps to Reproduce:
1. $tomboy
2. quit 
3.
  
Actual results:


Expected results:


Additional info:
mono-core-2.0-4.fc10.i386
gtk-sharp2-2.12.1-3.fc10.i386
gnome-sharp-2.20.0-2.fc10.i386

Comment 1 Matthias Clasen 2008-09-06 03:31:21 UTC
How do you quit tomboy ?

Comment 2 Tom London 2008-09-10 17:24:55 UTC
I get similar segfaults on log out or shutdown.

[root@tlondon ~]# grep tomboy /var/log/messages
Sep  8 14:47:18 tlondon kernel: tomboy[3521]: segfault at 591fb78 ip 0591fb78 sp bfcef67c error 4 in libpanel-applet-2.so.0.2.43.#prelink#.dhixrS (deleted)[593e000+d000]
Sep  8 17:52:53 tlondon kernel: tomboy[24486]: segfault at 6848b78 ip 06848b78 sp bf918bcc error 4 in libgail-gnome.so[6a82000+5000]
Sep  9 06:32:38 tlondon yum: Updated: tomboy-0.11.3-2.fc10.i386
Sep  9 06:43:49 tlondon kernel: tomboy[3116]: segfault at 58e9b78 ip 058e9b78 sp bf90724c error 4 in libpanel-applet-2.so.0.2.43 (deleted)[5ec1000+d000]
Sep  9 07:46:23 tlondon kernel: tomboy[3141]: segfault at 8b75b78 ip 08b75b78 sp bf7fdbac error 4 in libatk-bridge.so[8c1a000+6000]
Sep  9 10:18:28 tlondon kernel: tomboy[3205]: segfault at 5574b78 ip 05574b78 sp bfb4e68c error 4 in libgnomeprint-2-2.so.0.1.0[650b000+70000]
Sep  9 10:24:09 tlondon kernel: tomboy[7875]: segfault at 7468b78 ip 07468b78 sp bfc5da8c error 4 in libgvfsdbus.so[7c69000+24000]
Sep  9 10:35:15 tlondon kernel: tomboy[3421]: segfault at 6a8eb78 ip 06a8eb78 sp bf87a12c error 4 in libX11.so.6.2.0[6c75000+fe000]
Sep  9 10:36:57 tlondon kernel: tomboy[4254]: segfault at 110cb78 ip 0110cb78 sp bfb4a1dc error 4 in libglibsharpglue-2.so[14c0000+2000]
Sep  9 18:04:55 tlondon kernel: tomboy[4909]: segfault at 5e75b78 ip 05e75b78 sp bfa67f5c error 4 in libgnomeprint-2-2.so.0.1.0.#prelink#.FdifRV (deleted)[650b000+70000]
Sep 10 07:48:25 tlondon kernel: tomboy[3142]: segfault at fb6b78 ip 00fb6b78 sp bfc8832c error 4 in libgail-gnome.so[fc4000+5000]
Sep 10 09:14:03 tlondon kernel: tomboy[3163]: segfault at fb6b78 ip 00fb6b78 sp bfe1171c error 4 in libgail-gnome.so[fc4000+5000]
[root@tlondon ~]# 

Here is a bit of context:

Sep 10 09:14:03 tlondon gdm-simple-slave[2768]: DEBUG(+): GdmCommon: sending signal 15 to process 2769
Sep 10 09:14:03 tlondon gdm-simple-slave[2768]: DEBUG(+): GdmServer: Waiting on process 2769
Sep 10 09:14:03 tlondon kernel: tomboy[3163]: segfault at fb6b78 ip 00fb6b78 sp bfe1171c error 4 in libgail-gnome.so[fc4000+5000]
Sep 10 09:14:03 tlondon bonobo-activation-server (tbl-3880): could not associate with desktop session: Failed to connect to socket /tmp/dbus-pMTMmhE7Ly: Connection refused
Sep 10 09:14:04 tlondon gdm-simple-slave[2768]: DEBUG(+): GdmCommon: process (pid:2769) done (status:0)
Sep 10 09:14:04 tlondon gdm-simple-slave[2768]: DEBUG(+): GdmServer: Server died
Sep 10 09:14:04 tlondon gdm-simple-slave[2768]: DEBUG(+): GdmSignalHandler: Removing handler 10: signum=11 0x8053710

Comment 3 sangu 2008-09-13 16:30:50 UTC
Calls System.Environment.Exit() while the GTK main loop is still running : http://bugzilla.gnome.org/show_bug.cgi?id=528476

Comment 4 Ray Strode [halfline] 2008-10-14 16:55:48 UTC
So this was "fixed" in a version of gtk-sharp that we're shipping now, and the upstream report sangu referenced is open to address the poor-practice issue in tomboy.

Closing

Comment 5 Dan Winship 2008-10-14 19:56:42 UTC
Created attachment 320348 [details]
patch to work around the bug

The crash is fixed in the current release of gnome-sharp, 2.24.0.
We're currently shipping 2.20.0.

If it's too late to update it from 2.20 to 2.24, it's also fixed in gnome-sharp 2.20.1 and 2.20.2, so we could just upgrade to one of those.

Alternatively, we could just patch tomboy to intentionally leak a reference to its GnomeProgram, thereby preventing it from being destroyed atexit and trigger the bug. Patch for that attached.

Comment 6 Ray Strode [halfline] 2008-10-15 13:30:02 UTC
Ah, sorry for the confusion,
the upstream report said,

"This was with gtk-sharp 2.12.0 and the corresponding gnome-sharp... it was
fixed by a workaround in gtk-sharp 2.12.1 and it's corresponding gnome-sharp
version."

and we're shipping gtk-sharp2-2.12.3-1.fc10.x86_64

I removed tomboy from the panel and didn't get a segfault in dmesg so assumed the problem was fixed.

I just tried now running tomboy manually and going to the quit menu item and reproduced the issue.

Comment 7 Dan Winship 2008-10-15 13:40:00 UTC
whoops, i opened this bug in firefox while it was still NEW, and then didn't notice it was CLOSED when I attached the patch... (I guess you don't get a mid-air collision warning on the "add attachment" page?)

Anyway, yeah, the problem is that you need both gtk-sharp 2.12.1 AND gnome-sharp 2.20.1, and we only have the former.

Comment 8 Matthias Clasen 2008-10-15 22:54:11 UTC
So I guess we should look at getting gnome-sharp updated for F10...

Comment 9 Dan Winship 2008-10-16 18:41:08 UTC
filed a bug for updating gnome-sharp and gnome-desktop-sharp, which also revealed a mono-devel bug

Comment 10 Tom London 2008-10-27 22:15:11 UTC
Confirmed that updating to gnome-sharp, gnome-desktop-sharp to 2.24.0 fixes this.

Comment 11 Matthias Clasen 2008-10-27 23:23:17 UTC
[mclasen@localhost jhbuild]$ koji latest-pkg dist-f10 gnome-desktop-sharp
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
gnome-desktop-sharp-2.24.0-3.fc10         dist-f10              spot


Note You need to log in before you can comment on or make changes to this bug.