Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 460596 - Remove RHN::GPG and dependencies on perl OpenPGP
Summary: Remove RHN::GPG and dependencies on perl OpenPGP
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-08-28 20:55 UTC by Mike McCune
Modified: 2009-01-22 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:52 UTC


Attachments (Terms of Use)
0001-bugzilla-460596-first-step-at-removing-openpgp-fr.patch (deleted)
2008-10-30 17:55 UTC, Mike McCune
no flags Details | Diff

Description Mike McCune 2008-08-28 20:55:40 UTC
This possibly dead code pulls in deps on perl-Crypt-RIPEMD160 and perl-Crypt-OpenPGP which have some licensing issues.

Comment 1 Mike McCune 2008-10-30 17:55:46 UTC
Created attachment 321968 [details]
0001-bugzilla-460596-first-step-at-removing-openpgp-fr.patch

Comment 2 Devan Goodwin 2008-11-25 19:41:09 UTC
Removed and replaced with a call to gpg on the command line to verify signatures. Required packages removed from our spec-tree. 

Moving to modified.

Comment 3 Devan Goodwin 2009-01-14 21:13:14 UTC
[root@fjs-0-02 ~]# rpm -qa | grep Crypt
perl-Crypt-GeneratePassword-0.03-14.el5
perl-Crypt-DES-2.05-3.el5
[root@fjs-0-02 ~]# 

Packages no longer installed as of Spacewalk 0.4. Verified.


Note You need to log in before you can comment on or make changes to this bug.