Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4582 - limit command in /etc/csh.cshrc stops ~/.cshrc being read
Summary: limit command in /etc/csh.cshrc stops ~/.cshrc being read
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-18 08:46 UTC by jason
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-20 22:31:16 UTC


Attachments (Terms of Use)

Description jason 1999-08-18 08:46:10 UTC
On some machines --- probably those with less memory
and/or swap --- the line

   limit coredumpsize 1000000

in /etc/csh.cshrc returns an error code and causes the
TCSH and CSH shells to stop processing their configuration
files. Among other things, this means that users .cshrc
or .tcshrc files are not read.

Replacing this line by

   limit coredumpsize unlimited

fixes the problem.

This seems to be related to bug 4071.

Comment 1 Jeff Johnson 1999-08-20 22:31:59 UTC
Fixed in setup-2.0.4-1.

Comment 2 Jeff Johnson 1999-08-20 22:32:59 UTC
*** Bug 4071 has been marked as a duplicate of this bug. ***

When ksh is used as the login shell and tcsh is invoked
sometime thereafter within a shell or terminal this error
message appears:

limit: coredumpsize: Can't set limit

This does not occur when you change shell in a terminal to
ksh and then to tcsh - only when ksh is the login shell.

This has existed at least since 5.0

Cheers,
Dan

------- Additional Comments From dkl@redhat.com  07/16/99 14:09 -------
I have verified that this does occur as reported on a standard 6.0
install. It is being assigned to a developer for further review.


Note You need to log in before you can comment on or make changes to this bug.