Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 457414 - Adding 'Virtualization' entitlement for XEN system throws an error.
Summary: Adding 'Virtualization' entitlement for XEN system throws an error.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.4
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-31 14:54 UTC by Aleksandr Tarutin
Modified: 2009-01-22 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:47 UTC


Attachments (Terms of Use)

Description Aleksandr Tarutin 2008-07-31 14:54:19 UTC
Description of problem:
Error while enabling 'Add-on entitlements' for a XEN system: 
Could not automatically subscribe the system to the Spacewalk Tools Channel.
This channel contains packages required for virtualization. This is most likely
caused by a lack of channel entitlements.
Version-Release number of selected component (if applicable):


How reproducible:
From the Systems screen click on the system and on the next screen click
Properties. Check the 'Virtualization' checkbox for 'Add-On Entitlements' and
submit the page.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Devan Goodwin 2009-01-12 13:47:25 UTC
Hi Aleksandr, could you clarify, was this a Xen host or guest?

Comment 2 Devan Goodwin 2009-01-12 17:50:45 UTC
Cancel that request, have reproduced this and working on a solution.

Comment 3 Devan Goodwin 2009-01-12 20:08:13 UTC
Fixed in spacewalk git ec4734b065efac6647647a64f573715ed6e984b7.

Some Satellite specific logic here, there were three checks previously, one for RHN Tools channel, one for VT channel, and lastly one for availability of the rhn-virtualization-host package. 

Changed logic to only do the two channel checks in Satellite (as these are not relevant in Spacewalk).

Kept the package check but changed it to a warning in both, if rhn-virtualization-host is unavailable you can still add the virtualization entitlements to a system.

Comment 4 Devan Goodwin 2009-01-14 21:11:51 UTC
Verified in spacewalk 0.4.


Note You need to log in before you can comment on or make changes to this bug.