Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4568 - c-shell syntax errors in file /etc/profile.d/kde.csh
Summary: c-shell syntax errors in file /etc/profile.d/kde.csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-17 13:23 UTC by dc
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-18 15:29:28 UTC


Attachments (Terms of Use)

Description dc 1999-08-17 13:23:33 UTC
Syntax errors in /etc/profile.d/kde.csh (a c-shell script)
introduce problems for user accounts that have their shell
field in /etc/passwd set either to /bin/csh or /bin/csh.

Specifically, the syntax errors in kde.csh prevent the
startup files ~/.login and/or ~/.cshrc from executing.

I have resolved this bug by removing the syntax and logical
errors in kde.csh. Here is a copy of the original kde.csh,
followed by my repaired version. I leave it to Red Hat to
evaluate and/or improve upon my solution, as is appropriate:

Original version of kde.csh:

# KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
kdepath="${KDEDIR}/bin"
if ( echo ${PATH} | grep -q ${kdepath} ) then
  exit
endif

setenv PATH "${kdepath}:${PATH}"
# end orignal version

------------------------------------------

# repaired KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif

setenv KDEDIR /usr
set kdepath="${KDEDIR}/bin"

echo ${PATH} | grep -q ${kdepath}
if ( $? == 0) then
  exit
endif

setenv PATH "${kdepath}:${PATH}"

Thank you,
David Cohn,
Department of Technology
Market News International
100 William Street, 3rd Floor
New York, NY 10038
212-509-4444

Comment 1 dc 1999-08-17 13:37:59 UTC
Please excuse typo in previous commentary.  Phrase should have read
"either to /bin/csh or /bin/tcsh."

Thank you,

David Cohn

Comment 2 Jeff Johnson 1999-08-18 15:29:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.