Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456561 - [PPC] e-d-s computes wrong hmac-md5
Summary: [PPC] e-d-s computes wrong hmac-md5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 10
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 459691 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-24 17:36 UTC by Stefan Schulze Frielinghaus
Modified: 2009-06-17 13:04 UTC (History)
2 users (show)

Fixed In Version: 2.24.5-1.fc10
Doc Type: Bug Fix
Doc Text:
Version bump. Problem still exists. Also in F10.
Clone Of:
Environment:
Last Closed: 2009-03-04 10:39:28 UTC


Attachments (Terms of Use)

Description Stefan Schulze Frielinghaus 2008-07-24 17:36:32 UTC
Description of problem:
Since the update from 2.22.3-1 to 2.22.3-2 authentication does not work any
more. I'm using hmac-md5 over ssl to log into imap. Evolution does not say
anything except "Password wrong" <sarcasm>which is really helpful!</sarcasm>

A downgrade to e-d-s-2.22.3-1 "solved" the problem.

Version-Release number of selected component (if applicable):
2.22.3-2

Comment 1 Matthew Barnes 2008-07-24 17:52:26 UTC
Are you sure this is related to IMAP?  The 2.22.3-2 update was for address book
authentication.  I would not have expected it to affect email accounts.

What types of address books to you have configured?

Comment 2 Stefan Schulze Frielinghaus 2008-07-24 18:48:44 UTC
I don't know what the changes are between 2.22.3-1 and 2.22.3-2. But the result
is clear. When I install 2.22.3-2 then I can't log into my IMAP account and
dovecot (the IMAP server) in debug mode says that the MD5 hashes differ.

A downgrade to 2.22.3-1 "solves" the problem and I can login again. So from an
outside view I would say 2.22.3-2 has a bug.

I'm not sure what address books can be configured. I just use the "standard" one
and import some vCards. That's it.

If you need more informations just tell me.

Comment 3 Stefan Schulze Frielinghaus 2009-01-03 13:09:42 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Version bump. Problem still exists. Also in F10.

Comment 4 Milan Crha 2009-01-06 14:02:21 UTC
This seems to be specific for ppc, I see this working fine (without SSL) on an x86_64 Fedora 10. I found bug #459691, where this one seems to be a duplicate of, but reporter found an issue there and said it should be fixed. But it seems it isn't completely. I'll ask there.

Comment 5 Stefan Schulze Frielinghaus 2009-03-04 10:39:28 UTC
Since the last update (2.24.5-1.fc10), CRAM-MD5 works again. Bug closed.

Comment 6 Milan Crha 2009-06-17 13:04:47 UTC
*** Bug 459691 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.