Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456555 - cups inserts authentication requirement into printers.conf on its own
Summary: cups inserts authentication requirement into printers.conf on its own
Keywords:
Status: CLOSED DUPLICATE of bug 453951
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-24 16:45 UTC by Craig White
Modified: 2008-07-28 15:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-28 15:03:57 UTC


Attachments (Terms of Use)
cupsd.conf (deleted)
2008-07-24 16:45 UTC, Craig White
no flags Details

Description Craig White 2008-07-24 16:45:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):

- Definitely Fedora 9, on fedora-list discussion, I am told that this appeared
in Fedora 8

How reproducible:

- don't know. I can reproduce merely by issuing a print command in Firefox

Steps to Reproduce:
1. Created a printer that is accessed through Windows printer sharing
2. Can print anything including test pages as root
3. Go to print as User from Firefox, the following line is added automatically
to /etc/cups/printers.conf

  AuthInfoRequired negotiate

  which stops all user printing until that line is removed.


Actual results:

- cannot print until that line is removed from /etc/cups/printers.conf

Expected results:

- not having to do that

Additional info:

- note that this was an upgrade and not a 'clean install' but I ended up saving
my previous cupsd.conf and replacing it with the cupsd.conf.rpmnew file

see attached for /etc/cups/cupsd.conf (which should be the unaltered version
installed by cups rpm from fedora)

Comment 1 Craig White 2008-07-24 16:45:00 UTC
Created attachment 312580 [details]
cupsd.conf

Comment 2 Craig White 2008-07-25 20:02:58 UTC
I am of the opinion that it may be the application querying cups to see if
authentication is required the first time it tries to print. Anyway, I see there
are others with this issue...

http://forums.fedoraforum.org/showpost.php?p=1028522&postcount=1

http://ubuntuforums.org/showthread.php?p=5449368

Comment 3 Craig White 2008-07-27 15:20:03 UTC
A solution was suggested here...

https://www.redhat.com/archives/fedora-list/2008-July/msg03584.html

Comment 4 Tim Waugh 2008-07-28 15:03:57 UTC
I saw on the fedora-list mailing list that this is for a printer queue whose
device URI starts 'smb:', so this is a duplicate of bug #453951.

*** This bug has been marked as a duplicate of 453951 ***


Note You need to log in before you can comment on or make changes to this bug.