Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456543 - System Set Manager->Package->Verify - verification failure
Summary: System Set Manager->Package->Verify - verification failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-24 14:42 UTC by Brad Buckingham
Modified: 2009-01-22 16:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:45 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-24 14:42:00 UTC
Description of problem:

Verifying packages (systems->ssm->packages->verify):

The SSM allows the user to select a package to verify; however, it does not
allow them to select the architecture of the package being verified.  This can
result in package verification failures.

From initial analysis, impact to UI is anticipated.

Associate a system with SSM:
1. select Systems
2. click the box next to an x86_64 system

Schedule a package verify using SSM:
3. select System Set Manager -> Verify -> pick 64-bit Channel
4. select a package that you know is installed on the client with i386
5. run rhn_check -vvv on client at appropriate time have the verify action executed

Actual results:
If x86_64 client has only i386 version of the package (e.g. for libjpeg)
installed, the verify succeeds.
If x86_64 client has i386 and x86_64 versions of the package (e.g. for libjpeg)
installed, the verify fails.  It seems the issue is related to trying to compare
an i386 version of the package with an x86_64 version of the package.  

Expected results:
Verification should succeed if the package selected during scheduling, is
installed on the client.

Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 1 Jason Dobies 2008-12-09 21:34:15 UTC
Commit: 3a228d3352b7f961a80c4fcacc8f7f484c3d1e1b

Comment 2 Jesus M. Rodriguez 2009-01-09 21:19:43 UTC
Mark bug as modified once code is committed.


Note You need to log in before you can comment on or make changes to this bug.