Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456534 - perl back to requiring perl-devel by default
Summary: perl back to requiring perl-devel by default
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-07-24 14:08 UTC by Jeremy Katz
Modified: 2008-08-08 13:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-08 13:48:40 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2008-07-24 14:08:25 UTC
perl has regrown its dep on perl-ExtUtils-MakeMaker which means that perl-devel
is always being pulled in.  -devel packages should not be required for a default
install

Comment 1 Stepan Kasal 2008-07-28 10:38:15 UTC
You are suggesting that perl-devel crept in as a requirement of
perl-ExtUtils-MakeMaker.  We cannot see anything like that.

The default package list contains a meta-package named "perl-core," which is
proud to deliver "all of the perl bits and modules in the upstream tarball."
Indeed, the perl-core requires enlists them all: perl-devel, perl-ExtUtils-*,
perl-Test-*, perl-CPAN, and perl-Module-Build.

It seems perl-core is part of the default instalation.

What is the right solution here?
Perhaps perl-core might be split into two parts:
One would be named "perl-core-devel" or "perl-apple," would get the original
description ("all of the perl...", see above) and would require perl-core and
the development packages mentioned above.
The other one would be named "perl-core," and would maintain the rest of the
current huge requires list.
The base install would contain perl-core, but not perl-core-devel.

What do you think?

Comment 2 Jeremy Katz 2008-07-28 14:44:32 UTC
With today's rawhide, that is not the case.  perl-core is not listed in comps
and the dep tree pulling perl-devel is from
[katzj@aglarond comps]$ rpm -qpR
~/trees/rawhide/i386/Packages/perl-ExtUtils-MakeMaker-6.36-38.fc10.i386.rpm 
|grep devel
perl-devel  
[katzj@aglarond comps]$ rpm -qpR
~/trees/rawhide/i386/Packages/perl-5.10.0-38.fc10.i386.rpm |grep MakeMaker
perl(ExtUtils::MakeMaker)  
[katzj@aglarond comps]$ grep perl-core comps-f10.xml.in 
[katzj@aglarond comps]$

With F9 gold booted straight off the livecd
[root@localhost ~]# rpm -qR perl |grep MakeMaker
[root@localhost ~]#

Comment 3 Stepan Kasal 2008-07-28 15:20:42 UTC
(Oh, I examined obsolete rpms, sorry.)

You are right. That unfortunate dependency appeared first in perl-5.10.0-37.fc10.
Thank you for your report and for your patience explaining it to me. ;-)

After a quick examination, I cannot see anything in the diff which would warrant
the change, so I'm afraid it's caused by a change in the build environment. 
(That is to be confirmed by a scratch build.)  Stay tuned.

Comment 4 Stepan Kasal 2008-08-08 13:48:40 UTC
The problem was caused by enc2xs templates .../Encode/*.e2x, which, unlike the enc2x script itself, were packed in the main perl package.
Fixed in perl-5.10.0-39.fc10.


Note You need to log in before you can comment on or make changes to this bug.