Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456519 - error during nslogs package upgrade (sat510 -> sat520)
Summary: error during nslogs package upgrade (sat510 -> sat520)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring
Version: 520
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Steve Salevan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-24 11:56 UTC by Milan Zázrivec
Modified: 2018-10-20 03:10 UTC (History)
1 user (show)

Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-05 18:41:20 UTC


Attachments (Terms of Use)

Description Milan Zázrivec 2008-07-24 11:56:33 UTC
Description of problem:
Upgrade of Satellite 5.1.0 to Satellite 5.2.0, package nslogs, %post:

ln: `/home/nocpulse/var/commands/execute_commands.log': File exists
error: %post(nslogs-2.2.2-11.el4.noarch) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):
nslogs-2.2.2-11.el4 / Satellite 5.2.0

How reproducible:
Always

Steps to Reproduce:
Easiest way to reproduce the problem is to have an installed Satellite 5.1.0
or Satellite 5.1.1, download nslogs package from Satellite 5.2.0 ISO and
perform the package upgrade:
# rpm -U nslogs-2.2.2-...

Alternatively you can check /var/log/rhn/rhn-installation.log from
sat51{01} -> sat520 upgrade and see that nslogs package upgrades without
any errors.

Comment 1 Milan Zázrivec 2008-07-24 11:58:21 UTC
Sending        nslogs/BUILD.spec
Transmitting file data .
Committed revision 175539.

Comment 2 Milan Zázrivec 2008-07-24 14:08:28 UTC
nslogs-2.2.2-13 built and tagged in brew.

Comment 3 Brad Buckingham 2008-08-13 16:54:50 UTC
Mass move to ON_QA.

Comment 4 Steve Salevan 2008-08-28 17:04:46 UTC
Moving to VERIFIED, no errors found after following test plan on latest build of 520.

Comment 5 Steve Salevan 2008-10-27 15:26:15 UTC
Moving to RELEASE_PENDING, no errors found after 511->520 upgrade.

Comment 6 Brandon Perkins 2008-11-05 18:41:20 UTC
5.2.0 Satellite is now GA, bugs Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.