Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456510 - Errors during installation
Summary: Errors during installation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xguest
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-24 10:00 UTC by Paul Smith
Modified: 2008-09-09 19:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 19:26:03 UTC


Attachments (Terms of Use)

Description Paul Smith 2008-07-24 10:00:01 UTC
When I try to install xguest with the command

yum install xguest

I get the following errors:

Running Transaction
error: %pre(xguest-1.0.6-7.fc9.noarch) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping xguest-1.0.6-7.fc9

Paul

Comment 1 Daniel Walsh 2008-07-24 10:36:05 UTC
This is most likely where it failed.

What is the output of

(useradd -c "Guest" -Z xguest_u xguest || semanage login -a -s xguest_u xguest
|| semanage login -m -s xguest_u xguest)


Comment 2 Paul Smith 2008-07-24 11:01:40 UTC
Is the following:

$ useradd -c "Guest" -Z xguest_u xguest || semanage login -a -s xguest_u xguest
|| semanage login -m -s xguest_u xguest
bash: useradd: command not found
bash: semanage: command not found
bash: semanage: command not found
$ 

what you are asking for?

Paul



Comment 3 Daniel Walsh 2008-07-24 11:50:04 UTC
Sorry you have to run these as root with /usr/sbin in your path.

Comment 4 Paul Smith 2008-07-24 11:57:12 UTC
OK:

# /usr/sbin/useradd -c "Guest" -Z xguest_u xguest || /usr/sbin/semanage login -a
-s xguest_u xguest || /usr/sbin/semanage login -m -s xguest_u xguest
useradd: -Z requires SELinux enabled kernel

#

In fact, I have SELinux deactivated. Maybe, this is the problem.

Paul


 

Comment 5 Daniel Walsh 2008-07-24 13:05:27 UTC
Yes that would cause the problem.

But that would explain the problem.  Xguest is useless unless selinux is enabled.

Comment 6 Paul Smith 2008-07-24 14:32:49 UTC
If that is the case, the best to do is probably to close the bug. Sorry for
having disturbed you.

Is there some other program similar to xguest that does not use SELinux?

Thanks,

Paul


Comment 7 Daniel Walsh 2008-07-25 13:20:02 UTC
Why are you against enabling SELinux?

What features of xguest are you looking to use?

Comment 8 Paul Smith 2008-07-25 23:45:05 UTC
> Why are you against enabling SELinux?

I feared that it would reduce the performance/speed of my machine.
 
> What features of xguest are you looking to use?

After having activated SELinux, I could install xguest. Xguest corresponds to
the tool that I was looking for, and it is a great tool! Moreover, I do not
notice any reduction of my machine speed caused by the fact that now I have
SELinux active.

Many thanks,

Paul




Note You need to log in before you can comment on or make changes to this bug.