Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456485 - Pulseaudio does not start on boot
Summary: Pulseaudio does not start on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-24 01:41 UTC by Christopher Beland
Modified: 2008-10-25 02:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-25 02:18:07 UTC


Attachments (Terms of Use)

Description Christopher Beland 2008-07-24 01:41:14 UTC
Just after rebooting and logging in, when I started audacious in an xterm, I got
a message that it could not connect to PulseAudio, and to make sure that it was
running.  It was in fact not running.  The following errors appear in
/var/log/messages:

Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: polkit.c: Cannot set UID on
session object.
Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: main.c: setrlimit(RLIMIT_NICE,
(31, 31)) failed: Operation not permitted
Jul 23 21:14:40 diet-anarchy pulseaudio[2070]: main.c: setrlimit(RLIMIT_RTPRIO,
(9, 9)) failed: Operation not permitted
Jul 23 21:15:14 diet-anarchy pulseaudio[2274]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jul 23 21:15:14 diet-anarchy pulseaudio[2274]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jul 23 21:15:14 diet-anarchy pulseaudio[2274]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jul 23 21:15:14 diet-anarchy pulseaudio[2274]: pid.c: Daemon already running.
Jul 23 21:15:14 diet-anarchy pulseaudio[2274]: main.c: pa_pid_file_create() failed.

I can start pulseaudio as user "beland" and audacious can connect to it, though
I do get the following output:

N: main.c: Called SUID root and real-time/high-priority scheduling was requested
in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us
priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate
PolicyKit priviliges, or become a member of 'pulse-rt', or increase the
RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: pid.c: Stale PID file, overwriting.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

This is with pulseaudio-0.9.10-1.fc9.i386.  This didn't used to be a problem
with Fedora 9, though I did install some updates today.

Comment 1 Andre Robatino 2008-07-24 09:27:26 UTC
Probably a duplicate of bug #438284 or bug #444684.

Comment 2 Lennart Poettering 2008-08-06 14:06:32 UTC
An xterm? PA is being started in GNOME and KDE sessions only right. If you neither PA will not be running and your applications will not be able to find it.

Comment 3 Christopher Beland 2008-08-06 17:31:51 UTC
I do have a Gnome session, inside of which I have started gnome-terminal from the graphical menu.

Comment 4 Lennart Poettering 2008-10-02 00:58:13 UTC
Please check ~/.xsession-errors for an PA or ESD related output.

Have you played around with the "start ESD" checkbox in gnome-sound-properties or in GConf? They need to be *enabled*.

Comment 5 Lennart Poettering 2008-10-02 00:59:44 UTC
Also, have you seen the two bugs Andre linked? Are they relevant to you, do they apply to your case?

Comment 6 Christopher Beland 2008-10-25 02:18:07 UTC
I don't see a "start ESD" checkbox in gnome-sound-properties.

I haven't experienced this problem recently, and I rebooted twice today.  Perhaps the fixes pushed for those other bugs has cured this problem.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.