Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456475 - Multiple PDFs display in separate evince windows instead of in firefox tabs
Summary: Multiple PDFs display in separate evince windows instead of in firefox tabs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mozplugger
Version: 10
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 385831 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-23 22:58 UTC by Christopher Beland
Modified: 2018-04-11 09:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:13:54 UTC


Attachments (Terms of Use)

Description Christopher Beland 2008-07-23 22:58:39 UTC
Normally when I middle-click on a PDF link in firefox, a new tab opens and an
embedded evince window appears there and displays the document.  But sometimes
if I open multiple PDFs (perhaps especially if I do so in quick succession),
some of the tabs don't display properly.  Evince opens up in a separate window,
which I don't always notice.  When I click on the tab that I was expecting the
PDF to appear in, I just see the content of whichever tab I was viewing before
that one.  This is very confusing and can lead to closing the wrong tabs.

I'm sure where the bug is, but I'm using: 

firefox-3.0.1-1.fc9.i386
evince-2.22.2-1.fc9.i386
mozplugger-1.10.1-1.i386
gnome-python2-gtkmozembed-2.19.1-17.fc9.i386

Comment 1 Christopher Beland 2008-07-23 23:19:42 UTC
nspluginwrapper-1.1.0-4.fc9.i386 may also be implicated.

Comment 2 Gilboa Davara 2008-09-01 16:24:43 UTC
I can confirm this bug.
No matter what type of PDF viewer I try to embed (okular, evince, xpdf) I get the same result - an empty tab is opened (or the existing one is blanked-out), but the actual application is opened in a new window.

- Gilboa

Comment 3 Christoph Wickert 2008-09-05 10:14:27 UTC
+1, also affects Firefox.

Looks like a duplicate of bug # 385831.

Comment 4 Christoph Wickert 2008-09-05 10:49:57 UTC
Has this been reported upstream to the mozplugger devs? Maybe update to 1.10.2 which was released in half a year ago?

Comment 5 Matěj Cepl 2008-09-05 12:35:09 UTC
*** Bug 385831 has been marked as a duplicate of this bug. ***

Comment 6 Peter Backes 2009-01-10 01:53:08 UTC
I have the same problem.

This looks like a duplicate of bug #470509.

Comment 7 D. Hugh Redelmeier 2009-04-04 04:01:46 UTC
I experience this on Fedora 10 x86_64.

This bug is reported upstream against mozplugger:
 https://www.mozdev.org/bugs/show_bug.cgi?id=20686

As I understand it, evince has a stupid command line behaviour that is undocumented and this means mozplugger cannot handle it.  So Fedora should be configured so mozplugger is not asked to handle evince.

Here's the problem:

When an evince command is run (more precisely, when /usr/bin/evince is exec'ed), it checks to see if another process is running evince.  It may only consider such a process if it has matching characteristics such as UID or same display -- I don't know.

If such a process exists, the "work" is passed onto to the older process AND the newer process immediately exits.  So mozplugger will be confused: the process doing the display isn't the process that it fired up.

If such a process does not exist, this evince does the work.  But there is a twist: if another evince passes our evince process some more work, our evince won't exit until all the displaying is dismissed.  Again, very confusing to the invoker.

This evince behaviour cannot be managed by mozplugger.  So the configuration of Fedora should not let mozplugger handle .pdf files OR not tell it to invoke evince.

I think that evince's behaviour is quite wrong.  It violates conventional expectations of command line behaviour.  It is not documented.  I fear it has security implications (eg. does it check that all evince invocations have identical privileges?)

Comment 8 Ngo Than 2009-08-20 15:13:54 UTC
i cannot reproduce this with 1.12.1. It seems the issue is fixed in this version

Comment 9 Gilboa Davara 2009-08-30 15:58:58 UTC
+1. 
Seems to work just fine under F11.


Note You need to log in before you can comment on or make changes to this bug.