Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456472 - System->Activation Keys : unable to specify arch of packages associated with key
Summary: System->Activation Keys : unable to specify arch of packages associated with...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brad Buckingham
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 21:29 UTC by Brad Buckingham
Modified: 2009-01-22 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:41 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 21:29:24 UTC
Description of problem:

Systems -> Activation Keys:

Users do not have the ability to specify the architecture of packages to
associate with an Activiation Key. When packages are associated with an
Activation Key via the UI, only the package name is supported/used (e.g.
libjpeg). Since package names do not reflect the architecture, the user cannot
control the specific package that will be installed on the client. If the user
attempts to associate an architecture in the package name (e.g. libjpeg.i386),
the package is added to the list; however, it is ignored when the activation key
is used because a package by that name does not exist. 

From initial analysis, impacts to schema, UI, backend and API are anticipated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select Systems
2. select Activation Keys
3. update the list of packages associated with the key, attempting to specify
packages by name and arch (e.g. libjpeg, libjpeg.i386, libjpeg.x86_64)
4. re-register the client (rhnreg_ks) using the activation key specified
  
Actual results:
only those packages that were listed by package name will be installed during
the rhnreg_ks

Expected results:
all packages associated with the activation key should be installed

Additional info:

Note: when resolving this BZ, the implementation for communicating package
architecture may be handled differently than mentioned above...

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 2 Brad Buckingham 2008-10-21 17:43:50 UTC
Pradeep and I are working on the solution to this one under a remote branch (origin/multiarch).

The initial db and backend changes have been completed.  I'm now working on the UI changes which includes porting the page to java.

Comment 3 Brad Buckingham 2008-10-30 21:25:27 UTC
Changes have been made to UI and backend to address this BZ.  

UI commit: 41587d360f56d31991ce20ed0367b81a4d5ffc24.

This commit includes modifications to the UI to:
1. port the Activation Key -> Packages from perl to java
2. enhance the UI to enable users to optionally include a package architecture
when entering packages

Syntax:
packageName[.archLabel]

For example:
libjpeg
libjpeg.i386
a2ps.x86_64

If user provides a package name that does not exist in rhnPackageName, it will
be added.

If an archLabel is provided, it must be a valid one defined in
rhnPackageArch.label; otherwise, it will be assumed to be part of the package
name (e.g. libjpeg.i333 would generate a new package name by that name).

The XMLRPC APIs for ActivationKey have also been updated an will be documented
by a separate BZ.

Comment 4 Brad Buckingham 2008-10-30 21:39:33 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=469264 created to address the API modifications.  This BZ is not a dependency but include for additional info.

Comment 5 Brad Buckingham 2009-01-08 22:08:08 UTC
git commits: 
01658e62f8c9c047c614615549adfda0fba6b2d3
59ef64494c0b5ec5300962822f815d41000817d7

Comment 6 Brad Buckingham 2009-01-15 17:16:41 UTC
verified with spacewalk-java-0.4.14-1.el5


Note You need to log in before you can comment on or make changes to this bug.