Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456467 - System Set Manager->Package->Remove: incorrect package removed
Summary: System Set Manager->Package->Remove: incorrect package removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 480194 (view as bug list)
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 21:08 UTC by Brad Buckingham
Modified: 2009-02-11 20:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:40 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 21:08:06 UTC
Description of problem:

Removing packages (systems->ssm->packages->remove):

The SSM allows user to select a package to remove; however, it does not allow
them to select the architecture of the package being removed. As a result, all
instances of the package (e.g. i386 & x86_64) are removed during client update.

From initial analysis, impact to UI is anticipated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:Associate a system with SSM:
1. select Systems
2. click the box next to an x86_64 system

Install a package using SSM:
3. select System Set Manager -> Remove -> pick 64-bit Channel
4. schedule removal of an package (e.g. libjpeg) where both i386 and x86_64
versions are installed on the client
5. run rhn_check -vvv on client at appropriate time to install the package
  
Actual results:
client removes all instances of the package (e.g. libjpeg i386 & x86_64)

Expected results:
client removes only the version of the package requested/scheduled (e.g. libjpeg
i386)

Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 1 Jason Dobies 2008-12-02 21:27:19 UTC
Commit: aed9b834448f96c585f43f386e3d617011419ddb

Ported perl pages to java and added support for multiarch.

Comment 2 Jason Dobies 2008-12-02 21:29:32 UTC
Commit: 6fe6ac3db4a677b7801b09c25613653dfc50fbb0

Removed ported perl pages:

web/html/network/systems/ssm/packages/remove.pxt
web/html/network/systems/ssm/packages/remove_conf.pxt

Comment 3 Jay Dobies 2009-01-15 17:19:14 UTC
SSM package removal doesn't work at all:

Description of problem:
Everything in the workflow for removing packages through the SSM looks ok,
however after selecting confirm on the confirmation page, the message appears
saying "0 package removals have been scheduled" and no events are created on
the system.


Version-Release number of selected component (if applicable):
Spacewalk 0.4

How reproducible:
Always

Steps to Reproduce:
1. Navigate the SSM selecting one or more packages to remove
2. Hit confirm at the end of the workflow

Actual results:
A message indicates 0 packages are set for removal. No events are created.

Expected results:
The message should correctly display what is selected for removal and the
remove event should be created.

Additional info:

Comment 4 Jay Dobies 2009-01-15 17:19:28 UTC
*** Bug 480194 has been marked as a duplicate of this bug. ***

Comment 5 Jay Dobies 2009-01-15 21:49:30 UTC
Commit: a3f6de9627536832864b9ea86a9159a80925d4a7


Note You need to log in before you can comment on or make changes to this bug.