Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456463 - System Set Manager->Package->Install: incorrect package installed
Summary: System Set Manager->Package->Install: incorrect package installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 20:54 UTC by Brad Buckingham
Modified: 2009-02-11 20:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:38 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 20:54:44 UTC
Description of problem:

Installing packages (systems->ssm->packages->install)

Users are unable to install i386 packages on an x86_64 client from the server
when there exist both an x86_64 and i386 version of the package on the server.
Although the UI for SSM allows the user to select to install a package
associated with a specific architecture, when the package is installed for an
x86_64 server the package installed is always the x86_64.  The reason being, the
package architecture associated with the action is neither stored on the server
nor communicated to the client during update.

From initial analysis, impact to UI is anticipated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

Associate a system with SSM:
1. select Systems
2. click the box next to an x86_64 system

Install a package using SSM:
3. select System Set Manager -> Install -> pick 64-bit Channel
4. schedule install of i386 package (e.g. libjpeg)
5. run rhn_check -vvv on client at appropriate time to install the package

Actual results:
x86_64 package installed on client

Expected results:
i386 package installed on client

Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 1 Jason Dobies 2008-11-21 15:28:12 UTC
Commit: 707049ce8f6dedd4fc5be8e7ff1c4abfaba38ea5

Ported the SSM perl pages to java. Added architecture display to package selection table. Architecture ID information carried as part of the selected package and added to the scheduled package install action.

Perl pages removed:

network/systems/ssm/packages/
  choose_answer_files.pxt
  install.pxt
  install_channel.pxt
  install_conf.pxt

Comment 2 Jason Dobies 2008-11-21 20:51:42 UTC
Taking this back for a bit. Just remembered I forgot to get the tab bar at the top of the pages working (just sits on Overview and not Packages -> Install).

Comment 3 Jason Dobies 2008-12-02 14:31:35 UTC
Commit: d16bee50b193d20bcdaa38ed768875bf2d479814

Fixed the tab bar.


Note You need to log in before you can comment on or make changes to this bug.