Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456455 - System->Software->Remove: incorrect package removed
Summary: System->Software->Remove: incorrect package removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 19:37 UTC by Brad Buckingham
Modified: 2009-02-11 20:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:36 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 19:37:16 UTC
Description of problem:

Removing packages (systems->system->software->packages->remove):

If there are multiple instances of a package installed on a client, selecting to
remove an individual package results in all instances (e.g. i386 & x86_64) being
removed from the client. In this scenario, although a package associated with a
specific architecture is chosen from the UI, the package architecture is not
communicated to the client.

From initial analysis, impact to UI and backend are anticipated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select Systems
2. select an x86_64 system
3. select Software -> Packages -> Remove
4. schedule the removal of an i386 package (e.g. libjpeg)
5. perform rhn_check -vvv on the client at the appropriate time

Actual results:
client removes all instances of the package (e.g. libjpeg i386 & x86_64)

Expected results:
client removes only the version of the package requested/scheduled (e.g. libjpeg
i386)

Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 1 Jason Dobies 2008-10-29 14:58:19 UTC
UI changes finished. Updated the action query to persist the architecture.

GIT: f9b82cb676202ed169faea680410774e1dec33ee


Note You need to log in before you can comment on or make changes to this bug.