Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456452 - System->Software->List - should list multiple packages, if client has package installed for multiple architectures
Summary: System->Software->List - should list multiple packages, if client has package...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Pradeep Kilambi
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 19:28 UTC by Brad Buckingham
Modified: 2009-01-22 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:35 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 19:28:25 UTC
Description of problem:

Listing packages (systems->system->software->packages->list):

If the client has multiple instances of a package installed for different
architectures (e.g. i386 & x86_64), the package is only listed once.  

Observation: Although there are multiple versions of the package installed on
the client, the rhnServerPackage only has a single record. 

From initial analysis, impact to backend is anticipated.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. select Systems
2. select an x86_64 system
3. select Software -> Packages -> List
4. check the package list for a package that you know is installed on the client
for multiple architectures (e.g. libjpeg i386 & x86_64).  (Note: you may have to
manually install the 2 packages from the client, to observe this.)

Actual results:
Only 1 package is listed (w/o architecture)

Expected results:
Both packages should be listed and displaying the correct package architecture
in the package list.


Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.


Note You need to log in before you can comment on or make changes to this bug.