Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456451 - System->Software->List - incorrect package details displayed
Summary: System->Software->List - incorrect package details displayed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Pradeep Kilambi
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 19:14 UTC by Brad Buckingham
Modified: 2009-01-22 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:34 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 19:14:20 UTC
Description of problem:

Listing packages (systems->system->software->packages->list):

Selecting a package from the package list associated with an x86_64 client
displays the details of an x86_64 package, even if the client has the i386
package installed. This is due to the fact that the package data in
rhnServerPackage for x86_64 clients does not have the package architecture
populated. 

From initial analysis, impact to backend is anticipated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select Systems
2. select an x86_64 system
3. select Software -> Packages -> List
4. select a Package from the list that you know is i386 on the client (e.g. libjpeg)
  
Actual results:
Package details displayed are for the x86_64 package.

Expected results:
Package details displayed should be for the i386 package that is actually installed.


Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.


Note You need to log in before you can comment on or make changes to this bug.