Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456450 - Systems->System: unable to install i386 package on x86_64 system from server
Summary: Systems->System: unable to install i386 package on x86_64 system from server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Dobies
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2008-07-23 18:57 UTC by Brad Buckingham
Modified: 2018-10-20 00:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:29:31 UTC


Attachments (Terms of Use)

Description Brad Buckingham 2008-07-23 18:57:16 UTC
Description of problem:

Installing packages (systems->system->software->packages->install):

Users are unable to install i386 packages on an x86_64 client from the server
when there exist both an x86_64 and i386 version of the package on the server.
Basically, the UI does not allow the user to select the architecture of the
package to be installed and the package architecture is not communicated to the
client during update; therefore, the client will choose what it determines to be
the "best" selection, which will always be the x86_64 package on an x86_64 client. 

Impacts to UI and backend are anticipated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select Systems
2. select an x86_64 system
3. select Software -> Packages -> Install
4. select a Package that exists for both x86_64 and i386 (e.g. libjpeg)
5. schedule package install
6. run rhn_check -vvv on client at appropriate time to install the package 
  
Actual results:
On 3, observe that the package list does not indicate package architecture.
After 6, observe that the x86_64 version of the package has been installed.

Expected results:
On 3, user should be able to select any package that is available to the system;
therefore, if both i386 and x86_64 is available, they should see both listed.
After 6, the package selected (e.g. i386) should be installed

Additional info:

https://fedorahosted.org/spacewalk/wiki/MultiArchEnhancements - Refer to wiki
page for more details on this issue. This page contains proposed solution;
however, since the solution details can change as the issue is further
investigated, it is not being included in the bug report.

Comment 1 Devan Goodwin 2008-09-05 14:48:51 UTC
Bumping to space03.

Comment 3 Brad Buckingham 2008-10-21 17:54:20 UTC
Bumping to space04 and reassigning to jdobies.

Comment 4 Jason Dobies 2008-10-28 14:55:22 UTC
- Changed query to return the package architecture
- Changed package installation UI to display the architecture version

Git commit: 41abe17d9f57bffecdbafd43356404bd888ca26e

Comment 5 Jay Dobies 2009-01-09 21:34:37 UTC
*** Bug 477634 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.