Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456443 - ptrace: reparent-zombie testcase FAILs
Summary: ptrace: reparent-zombie testcase FAILs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.7
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Vitaly Mayatskikh
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 461297
TreeView+ depends on / blocked
 
Reported: 2008-07-23 18:00 UTC by Jan Kratochvil
Modified: 2009-05-19 15:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-19 15:43:07 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2008-07-23 18:00:14 UTC
Description of problem:
The testcase program
http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/tests/reparent-zombie.c?cvsroot=systemtap
should PASS as on F-9 (utrace) kernels and (reportedly) upstream 2.6.26+.
(/proc/PID/status should not be left Zombie for parents with SIG_IGN SIGCHLD.)

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-78.EL.x86_64

How reproducible:
Always.

Steps to Reproduce:
wget -O reparent-zombie.c
http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/tests/reparent-zombie.c?cvsroot=systemtap;
gcc -o reparent-zombie reparent-zombie.c -Wall -ggdb2 -D_GNU_SOURCE -pthread;
./reparent-zombie; echo $?

Actual results:
24649 left in State:	Z (zombie)
1

Expected results:
0

Additional info:
It was reported by Roland at http://sourceware.org/systemtap/wiki/utrace/tests
as "fixed upstream after 2.6.26".

reparent-zombie-clone testcase also FAILs but only with the same result as this
Bug's testcase reparent-zombie with no kernel crash.  IMO kernel crash was the
reason for reparent-zombie-clone so it should get fixed along by this Bug.

Comment 1 Vitaly Mayatskikh 2008-07-30 13:52:11 UTC
The bug is not reproducible not only in upstream kernel (2.6.27-rc1), but in F-9
(2.6.25.11-97) and RHEL-5 (2.6.18-92.1.6) also. I see it only in RHEL-4. Are you
sure about 2.6.26+?

Comment 2 Jan Kratochvil 2008-07-30 15:42:51 UTC
(In reply to comment #1)
> The bug is not reproducible not only in upstream kernel (2.6.27-rc1), but in
> F-9 (2.6.25.11-97) and RHEL-5 (2.6.18-92.1.6) also. I see it only in RHEL-4.
> Are you sure about 2.6.26+?

(My comment #0)
> It was reported by Roland at http://sourceware.org/systemtap/wiki/utrace/tests
> as "fixed upstream after 2.6.26".

I do not see any contradictions.
I agree with you that:

RHEL-4 is broken - This Bug.
RHEL-5 is OK (expecting due to utrace - instead of upstream ptrace)
F-9 is OK (expecting due to utrace - instead of upstream ptrace)
upstream 2.6.27-rc1 is OK (as Roland said it is fixed upstream after 2.6.26)
My test on 2.6.25.6-55.vanilla.fc9.x86_64 shows it is broken (as expected)


Comment 3 RHEL Product and Program Management 2008-09-03 13:00:59 UTC
Updating PM score.

Comment 4 Linda Wang 2009-04-07 13:30:06 UTC
move back to ASSI, the patch posted need follow up after Roland's feedback.


Note You need to log in before you can comment on or make changes to this bug.