Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 456420 - syntax error in expression when building packages
Summary: syntax error in expression when building packages
Keywords:
Status: CLOSED DUPLICATE of bug 456103
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-23 14:00 UTC by Karsten Hopp
Modified: 2008-07-24 07:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 07:49:17 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2008-07-23 14:00:37 UTC
Description of problem:
hagen:[RHEL-2_1] >make prep                                             
error: syntax error in expression                                       
error: vim.spec:8: parseExpressionBoolean returns -1                    
error: query of specfile vim.spec failed, can't parse                   
error: syntax error in expression                                       
error: vim.spec:8: parseExpressionBoolean returns -1                    
error: query of specfile vim.spec failed, can't parse 

Version-Release number of selected component (if applicable):
rpm-4.5.90-0.git8426.9

How reproducible:


Steps to Reproduce:
1. use a spec file with the following lines (used to switch features on/off)
%define alpha %{nil}
%define rescue %{nil}
%define rel 7.22
%if "%{alpha}" != ""
Release: 0.%{alpha}.%{rel}%{rescue}
%else
Release: %{rel}%{rescue}

This bails out at the %if line, same happens p.e. for
%if %alpha
%if %{alpha}
%if "%{alpha}" == "%{nil}"
  
Actual results:
hagen:[RHEL-2_1] >make prep                                             
error: syntax error in expression                                       
error: vim.spec:8: parseExpressionBoolean returns -1                    
error: query of specfile vim.spec failed, can't parse                   
error: syntax error in expression                                       
error: vim.spec:8: parseExpressionBoolean returns -1                    
error: query of specfile vim.spec failed, can't parse

Comment 1 Panu Matilainen 2008-07-24 07:49:17 UTC

*** This bug has been marked as a duplicate of 456103 ***


Note You need to log in before you can comment on or make changes to this bug.